Hello Guest it is February 21, 2024, 11:31:08 PM

Author Topic: Galil Softlimits Jog  (Read 3537 times)

0 Members and 1 Guest are viewing this topic.

Galil Softlimits Jog
« on: November 18, 2010, 12:43:41 AM »
I am having some problems with jogging when the softlimits are on.
I have a cincinnati arrow, which I am fitting mach3 on. Also use the DMC2143 and a RIO 47120. Ive read a post, brought back up a year ago, with the same problem, but haven't found out whether they were able to fix it or not.
Jogging is fine without the softlimits on. When I activate the softlimits button, the X+ and X- both jog to the X- direction and Y+ and Y- Both jog in the Y- direction.
Z jog however is fine. checked the galil plugin version (V4.4) then deleted it in the mach3 plugin directory and reinstalled it. No change.
Anybody any thoughts?

Regards, Albert

Offline kcrouch

*
  •  193 193
  • In way too deep!!!
    • View Profile
Re: Galil Softlimits Jog
« Reply #1 on: November 18, 2010, 08:13:23 AM »
Albert,
I only see this trouble if I'm jogging before homing the machine. In that case, the Galil's soft limits won't be initialized and may halt motion in one direction prematurely. Following a home to home or limit switches, everything works well again.
Kenny
Having way too much fun! Something must surely be wrong.
Re: Galil Softlimits Jog
« Reply #2 on: November 18, 2010, 08:13:16 PM »
Ken,
Jogging is fine without the softlimits on. Also before I home any axis. Thought about the motor setup in galil, using the MT and CE commands,
I use reversed servomotor in mach3 for the Y and Z direction.(thought yhat might be a problem)
But I dismissed that aswell, because the Z-axis is doing fine (with or without the softlimits on)
I think it must be a software thing or a setup configuration on the galil card, I overlooked. (maybe that initialization of the softlimits on the galil you talked about,
it might need some configuration)
I will hardwire the jog commands to some inputs, just to try whether the same thing is happening. But I am not very optimistic about that.
I 'll think some more about it,
Albert
Re: Galil Softlimits Jog
« Reply #3 on: November 19, 2010, 01:08:40 AM »
Guys, Don't bother,
Got it figured out. on the home and limits the X and Y were set on reverse, Changed that back and modified
the servo configuration on the galil to MT 1,1,-1 and CE 0,0,2, In the plugin motor mapping just selected:
x -servo, y-servo and z-servo reversed. Just posted this in case anybody had the same problem.
Thanks anyway
Albert

Offline kcrouch

*
  •  193 193
  • In way too deep!!!
    • View Profile
Re: Galil Softlimits Jog
« Reply #4 on: November 19, 2010, 07:55:16 AM »
Just want to note that the plugin overwrites any MT and CE settings that you burn in to the Galil. It was the switch to axis reversed in the plugin that apparently fixed the trouble.

Kenny
Having way too much fun! Something must surely be wrong.