Hello Guest it is December 07, 2019, 11:09:12 AM

Author Topic: spindle speed reads (-)  (Read 3955 times)

0 Members and 1 Guest are viewing this topic.

spindle speed reads (-)
« on: November 03, 2010, 08:29:01 PM »
I have recently set up my old denford orac lathe with mach3. All seems well apart from spindle speed. when the spindle starts up it reads it as a - figure. ie if i input m03s1000 in the mdi page it says the speed is -1000rpm. Ive changed debound settings and tried active low/high. Ive set up the spindle pulley to min 200 max 2100. I'm mega lost on this. anyone got any idea's??

Offline RICH

*
  • *
  •  7,375 7,375
    • View Profile
Re: spindle speed reads (-)
« Reply #1 on: November 04, 2010, 06:50:44 AM »
There was a problem with computer cpu's with a fast bus speed >2.1 Ghx which would cause the negative  spindle speed in the DRO.
That was fixed and you need to use version 3.042.33 and later.

RICH
Re: spindle speed reads (-)
« Reply #2 on: November 04, 2010, 09:39:43 AM »
ah yes i have updated mach to a newer version and it now reads the spindle speed.. but the problem i have now is it seems to read the spindle speed to fast and will not calibrate
Re: spindle speed reads (-)
« Reply #3 on: November 04, 2010, 01:47:30 PM »
are your speed readings low, or only go up to a certain speed
Re: spindle speed reads (-)
« Reply #4 on: November 06, 2010, 09:42:02 AM »
No... for example. if i input m03 s1000. it will read the speed at 2500rpm.
Re: spindle speed reads (-)
« Reply #5 on: November 06, 2010, 09:46:47 AM »
and the spindle is running at 1000 not 2500
« Last Edit: November 06, 2010, 09:48:22 AM by angel tech »
Re: spindle speed reads (-)
« Reply #6 on: November 06, 2010, 09:50:42 AM »
yep.. my lathe has a max spinlde speed of 2000rpm so i am quite sure its not doing that speed
Re: spindle speed reads (-)
« Reply #7 on: November 06, 2010, 10:29:48 AM »
check the index debounce in port and pins/general config, and set it to 0.
Re: spindle speed reads (-)
« Reply #8 on: November 06, 2010, 12:17:34 PM »
yea i have been playing about with that. also the spindle pully ratio. ive set it at 0.7. I got this number from the max spindle speed of 2000rpm and max motor speed of 1400rpm. so 2000/1400= 0.7 am i right in doing it that way? seems to of helped a little bit.
Re: spindle speed reads (-)
« Reply #9 on: November 06, 2010, 11:07:48 PM »
i ment 1400/2000=0.7