Hello Guest it is September 20, 2019, 06:35:51 AM

Author Topic: Homing Softlimit Issues  (Read 2590 times)

0 Members and 1 Guest are viewing this topic.

Homing Softlimit Issues
« on: October 28, 2010, 09:36:09 AM »
I have a slight problem... I have a static head dummy Z axis and I can set my zero position relative to it and reference home position which ends up being X-2.0 Y-3.0... I try to set my softlimits but it does not like that negative value of the home position. I can't understand why there is no change if I try to set my softlimits with a negative number? I jog back and forth - the limits work but I can't get it within the proper range I need to run my programs with the softlimits button activated, it comes up with an error message that I am out of the softlimit range.

I can run my programs without any issues from my zero position by pressing GOTO zero without the softlimits activated but I don't want to run without limits set as there is a possibility of jogging off and crashing into the proxy switches... this happened when I tried to run a test program by mistake from the home position and not from my zero position.

At one time I did have my home setup with positive numbers and I was easily able to set the softlimits correctly... I have since lost that setup and need to get it back... Why is this so critical?

It's a bit confusing why it does not seem to work with home values being negative relative to my Zero work position (which all my programs are written from)

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Homing Softlimit Issues
« Reply #1 on: October 28, 2010, 10:15:52 AM »
Soft limits are in machine cords so X and Y Min should be zero and X and Y Max  should be the travel of the axis.
If you home to the negative end of the axis travel then all is fine but if you home positive end then you will need to set a home off value equal to the distance the home switch is away from fully negative (machine coords zero)

Hood
Re: Homing Softlimit Issues
« Reply #2 on: October 28, 2010, 08:12:39 PM »
Hood to the rescue again! - works as explained... Thanks!

We thought that our home position was at one time positive, but that was a mistake... the only thing wrong was our X/Y min setting - we just jogged till it made that funky sound and all was good.

We ship tomorrow.

Cheers, Alex.

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Homing Softlimit Issues
« Reply #3 on: October 29, 2010, 02:13:38 AM »
:)