Hello Guest it is October 22, 2019, 03:34:36 PM

Author Topic: Parallel Port2 no Led activity  (Read 3813 times)

0 Members and 1 Guest are viewing this topic.

Parallel Port2 no Led activity
« on: October 27, 2010, 04:39:37 PM »
Hi Dave,

I have 3 inputs and 4 outputs on PP 2, all are working fine.  On the Hardware page – PP Driver Tab all are grayed out.
 
PP1 has activity but bit 14 (output) is on all the time.  This is a drive enable bit and toggles on / off on the Hardware Signals Tab.

version R3.043.022  - 0.4.3(beta12)

Ron
Re: Parallel Port2 no Led activity
« Reply #1 on: October 27, 2010, 05:08:42 PM »
Hi Ron,
Here are the first thoughts that come to mind re your 2nd PP:

1) Is the 2nd port enabled in the mach config port & Pins ?
If you're using the port, I'd guess yes. if the a PP is not enabled in mach, MSM greys out the port's pins on the PP driver page.

2) Is the 2nd PP set up with "pins 2-9 as inputs" checked in config ports&Pins?
MSM only handles the 2nd port display when the port is set up as "input". I'd need to go look at the code, I can't remember off the top of my head if MSM also greys out the pins for PP2 if it is set as output. In any case, the 2nd PP display panel LED pin layout corresponds to the input case. (having the 2nd PP panel visually handle the "output" case was not implemented in the beta).

Dave
Author of the MachStdMill Extensions for Mach3
www.CalypsoVentures.com
Re: Parallel Port2 no Led activity
« Reply #2 on: October 27, 2010, 06:10:39 PM »
Dave

Second PP was enabled and working fine, however pins 2-9 was not checked.  Checking pins 2-9 did bring PP2 LED's to life but I won't be able to use it that way with my setup. 

Thanks,  Ron
Re: Parallel Port2 no Led activity
« Reply #3 on: October 27, 2010, 06:23:40 PM »
Ron,

My apologies -

The bad news: the PP2 display is only for input in beta 12. Output mode is on my list of things to add when I get some time to do so.   :(

The good News: This only impacts the display of PP2 leds on the PP driver page - not the actual functioning of the PP itself.  PP2 will work however you set it up in Mach (input or output). There is no problem using PP2 in output mode with MSM - MSM just can't currently show you the right leds for output mode - but the system will function just fine anyhow.   :)

I know it would be nice to have the page handle both modes for PP2.
Does it help to realize that 1024 doesn't give any rational display of PP pins for either PP1 or PP2?  ::)

Dave






« Last Edit: October 27, 2010, 06:25:30 PM by DaveCVI »
Author of the MachStdMill Extensions for Mach3
www.CalypsoVentures.com