Hello Guest it is August 25, 2019, 11:40:07 PM

Author Topic: mach 3.042 install on fresh win XP install and driver test won't work  (Read 9207 times)

0 Members and 1 Guest are viewing this topic.

I just finished reinstalling win XP on my computer.  this is a dedicated setup for mach to run my cnc.  i had it running before but windows would lock up. so this time i reloaded windows with using the optimization suggestion of loading with F5.  now when i run mach 3 i can't get anything to do anything.  i even went out and bought a seperate PCI serial adapter card thinking there maybe a missing driver in windows with the new install and still nothing.  i can't even get my limit switches to trigger on the auto detect function. 

i know this seems really stupid as i had it running before, but i'm at a loss as to whats going on now.  btw the computer is a 3ghz pentium with 2 gigs of ram.  this is the same computer i ran before with mach 3 just a new install of windows xp.

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: mach 3.042 install on fresh win XP install and driver test won't work
« Reply #1 on: October 19, 2010, 03:10:10 PM »
You say in the title that the driver test wont work, what does it actually do or say when you try and run it?
Hood
Re: mach 3.042 install on fresh win XP install and driver test won't work
« Reply #2 on: October 19, 2010, 03:33:04 PM »
it says that the driver test that system is under mach 3 control but nothing happens on the screen.

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: mach 3.042 install on fresh win XP install and driver test won't work
« Reply #3 on: October 19, 2010, 04:10:56 PM »
Try removing the Mach3 pulsing engine via device manager then trying the driver test again. If that doesnt work then maybe try the specialdriver.bat

Hood
Re: mach 3.042 install on fresh win XP install and driver test won't work
« Reply #4 on: October 19, 2010, 04:26:13 PM »
ok, i reinstalled mach 3 complete after manually removing the driver through device manager.  i did get the driver test to work once and now it tells me that it can't find the vectors.

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: mach 3.042 install on fresh win XP install and driver test won't work
« Reply #5 on: October 19, 2010, 04:31:53 PM »
Try installing an older version and see if it works.
Hood
Re: mach 3.042 install on fresh win XP install and driver test won't work
« Reply #6 on: October 19, 2010, 04:59:50 PM »
I really didn't want to use an older version and nothing changed in the hardware, only the software change.  i am tempted to reload windows XP with the standard installation and then go through and disable features.  maybe there is something missing with this stripped version that mach needs to run well with my hardware configuration.

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: mach 3.042 install on fresh win XP install and driver test won't work
« Reply #7 on: October 19, 2010, 05:02:48 PM »
I was just meaning to install the older version to see if it works, if not then its almost certain its a XP issue. But as it wont take long to reinstall XP it might be the way to go.
Hood
Re: mach 3.042 install on fresh win XP install and driver test won't work
« Reply #8 on: October 27, 2010, 06:46:08 PM »
ok heres where i am at...  i did load the old software and it didn't work either.  so i reinstalled windows xp with the standard configuration.  it didn't work with either as well.  i finally read a post on here and went into the bios and change the PP to EPP and now its working with the new 3.042 software.  however, as before, mach 3 will lock up the computer after a certain amount of time of just being on.  even without a running a program if i leave it just on with or without the servos engaged it locks up.  then i have to reboot the computer.  i did try the optimization stuff and it doesn't seem to help this problem.   any ideas?  i am tempted to reinstall with the F5 load of xp and see if it works now that pp is set to EPP.  i am trying to get to the point of having a reliable system but i can't keep rebooting up every time it locks up. 

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: mach 3.042 install on fresh win XP install and driver test won't work
« Reply #9 on: October 27, 2010, 07:04:38 PM »
Does the driver test look ok?
What CPU % is the system running at when Mach is open?
Does it only crash with Mach open or does it crash with just windows
Hood