Hello Guest it is February 28, 2021, 05:51:24 AM

Author Topic: Mach3 crashes with known program  (Read 1780 times)

0 Members and 1 Guest are viewing this topic.

Mach3 crashes with known program
« on: October 16, 2010, 09:41:51 PM »
I have a real bad problem with mach3. I am running a 3 axis vertical mill. Here is what happens:

I load a program I have run successfully many times before. I set the zeros and hit start. The spindle comes on, but instead of accelerating to the commanded RPM (say M3 S7000), it gives an error "commanded RPM too low, defaulting to minimum". The spindle then runs at the minimum speed (say 800RPM). Then it disregards the rest of the program and just runs -Z until it crashes or I hit E-stop.

If I click the spindle override to 101% the spindle will immediately accelerate to the correct RPM. That seems to also stop the maching from dropping in Z. The spindle speed seems to ocsillate though. It rises and falls about 500RPM every 5 or 6 seconds.

What is going on here? I'm running a Dell Optiplex 260. I already ruined one fixture with this error. It doesn't seem to happen everytime. Restarting the computer sometimes makes the problem go away for a while.

Thanks everyone

-Wes
« Last Edit: October 16, 2010, 09:43:24 PM by ewlsey »

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 crashes with known program
« Reply #1 on: October 17, 2010, 02:21:21 AM »
Can you attach your xml and the code and also the spindlespeed.m1s from the macro folder of your profile.
Might not be able to simulate here but will give it a go and see if I can ayt least get it to do the same.
Hood