Hello Guest it is October 22, 2019, 08:02:26 AM

Author Topic: Elapsed Time output stopping during run  (Read 3275 times)

0 Members and 1 Guest are viewing this topic.

Elapsed Time output stopping during run
« on: October 14, 2010, 06:19:59 PM »
I've recently noticed that, sometimes during the run of a program, the Elapsed Time counter will be stopped.  It will have a value, like it counted up to a certain point and then stopped.  It's no big deal, but it makes me wonder what's causing it.

I'm using Version 3.042.020

Anybody got any ideas?
Bill (the Cat) Shubert

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Elapsed Time output stopping during run
« Reply #1 on: October 15, 2010, 03:12:45 AM »
Try reducing the look ahead to see if that makes things a bit better.
Hood
Re: Elapsed Time output stopping during run
« Reply #2 on: October 15, 2010, 10:52:48 AM »
Thanks for the reply Hood!

I'm not at my machine right now, so I can't say exactly what my look ahead value is.  I do know that it was set based on research I did regarding CV mode and I doubt I would want to change it.

I am curious why the look ahead value would affect the elapsed time counter.  In particular, why would it just stop?
Bill (the Cat) Shubert

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Elapsed Time output stopping during run
« Reply #3 on: October 15, 2010, 10:59:50 AM »
I think there is a problem with the timer and if for example you have 200 for look ahead the timer will stop when you are 200 lines from the end. Could be totally wrong as its just a guess and its something I never look at, I dont even have it on my screens.
Hood
Re: Elapsed Time output stopping during run
« Reply #4 on: October 15, 2010, 11:17:24 AM »
Thanks again Hood!

I don't think the look ahead problem you describe is causing my problem.  I was running the same program multiple times the other day and, on occasion, I would notice the the timer would be stopped at widely different times during the program run.  Sometimes the counter would be stopped at only 10 or 12 seconds.  Other times it would be stopped at 20+ minutes????

Like I said before, it's not a big deal.  The failure of the elapsed timer doesn't seem to be affecting any thing else. I'm just one of those anal types that likes to have a reason for things ;D
Bill (the Cat) Shubert
Re: Elapsed Time output stopping during run
« Reply #5 on: June 04, 2011, 10:26:02 AM »
Not sure if you ever found a solution to your problem, but I had a similar issue.  What I found resolved the problem was to disable my network card.  My CNC machine is connected to my home network, so if necessary, I can update the operating system.  When the network card was active, the elapsed timer would stop at random times.  When it was disabled, it works fine.
Re: Elapsed Time output stopping during run
« Reply #6 on: June 04, 2011, 01:06:20 PM »
Not sure if you ever found a solution to your problem, but I had a similar issue.  What I found resolved the problem was to disable my network card.  My CNC machine is connected to my home network, so if necessary, I can update the operating system.  When the network card was active, the elapsed timer would stop at random times.  When it was disabled, it works fine.

Thanks for the idea.  I don't have this machine connected to any network, but I do have a network card.  I'll try disabling it and see what happens.

Thanks again!
Bill (the Cat) Shubert

Online Tweakie.CNC

*
  • *
  •  7,956 7,956
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Elapsed Time output stopping during run
« Reply #7 on: June 05, 2011, 04:24:00 AM »
I would be interested in hearing the result Bill.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.