Hello Guest it is December 14, 2019, 02:14:35 PM

Author Topic: Z axis only moves in one direction when jogging?  (Read 4742 times)

0 Members and 1 Guest are viewing this topic.

Z axis only moves in one direction when jogging?
« on: October 08, 2010, 09:19:26 AM »
I installed Mach 3 v2.63 on my machine after my PC crashed and wouldn't start.  I ran this machine successfully for almost two years.  In setting up my pinout in which Z pins out port 1 on pin 6 and 7 stp and dir respectively.  I only get clockwise rotation.

I swapped out the stepper (IMS Mdrive 23) and that had no result.  Swapped keyboard to rule that out. Pinned out onto the X axis and that didn't help.  Finally I decide to change the direction pin to 8 instead of 7 because I thought it might be something with the port.  That produced no result.

I figured before I went any further I would throw it out there.

Thanks.
Re: Z axis only moves in one direction when jogging?
« Reply #1 on: October 08, 2010, 10:46:58 AM »
check you haven't got a pin number duplicated
Re: Z axis only moves in one direction when jogging?
« Reply #2 on: October 08, 2010, 11:31:34 AM »
I'm all good in that respect. No dupe's.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Z axis only moves in one direction when jogging?
« Reply #3 on: October 08, 2010, 01:53:11 PM »
Is it just when jogging or does it also happen if you MDI a move one way then the other?
Have you tested at the port with a voltmeter to see if the dir signal changes when you jog one way then the other?
Hood
Re: Z axis only moves in one direction when jogging?
« Reply #4 on: October 13, 2010, 12:20:35 PM »
Turned out to be a short in the wiring harness.  What a pain.