Hello Guest it is September 16, 2019, 07:09:56 PM

Author Topic: Problems getting mach3 to talk to smoothstepper  (Read 13629 times)

0 Members and 1 Guest are viewing this topic.

Offline thosj

*
  •  352 352
    • View Profile
Re: Problems getting mach3 to talk to smoothstepper
« Reply #10 on: October 08, 2010, 08:30:17 AM »
That would be correct. I'm the only user on all my computers, so I'm administrator!! I forget about that because SOMETIMES, there is something, and I think drivertest.exe is one of those, that STILL wants Run as Administrator checked in the compatibility tab. Not sure I remember that correctly as I don't use PP any more so don't run drivertest.exe. I guess Administrator has two meanings.

Offline Jeff_Birt

*
  •  1,107 1,107
    • View Profile
    • Soigeneris
Re: Problems getting mach3 to talk to smoothstepper
« Reply #11 on: October 08, 2010, 10:25:33 AM »
Quote
You DO mean right clicking the Mach shortcut, Properties, Compatibility, and setting Run as Administrator?

It all depends on how you have UAC (User Access Control) configured. If you have it turned off then you will likely not have an issue. I have UAC on and my Mach link set to Run As Administrator so I get a pop-up window asking me if I want to allow it to maker changes to my computer each time I launch it. (Kind of annoying but not a big deal, it is a very good safety net against various viruses, etc.) The best thing to do if one is in doubt is to 'Run As Administrator'.
Happy machining , Jeff Birt
 

Offline thosj

*
  •  352 352
    • View Profile
Re: Problems getting mach3 to talk to smoothstepper
« Reply #12 on: October 08, 2010, 11:10:44 AM »
I have UAC on DEFAULT and I don't get a prompt when starting Mach3. I've never set Mach3 to Run as Administrator and I don't get a prompt. Do you have UAC all the way to the top? Default is second position from top.
Re: Problems getting mach3 to talk to smoothstepper
« Reply #13 on: October 08, 2010, 01:17:01 PM »
Thanks for the help, I finially got mach 3 runing and now doing the happy dance..

jim
Re: Problems getting mach3 to talk to smoothstepper
« Reply #14 on: March 15, 2011, 10:58:24 PM »
I thought I would add this.  Some software programs require that in order save such things as registration numbers, license numbers etc., the user must "run the program as administrator" in order for the update to "take."

This is true even though the program may run normally as a less powerful user than administrator rights.
This is function of UAC (security) under windows 7.

I suspect that the failure to "remember" the choices of using default or custom settings as mentioned in original post is one of these software flukes that require administrator rights to make the choice and have the software "recognize" it even though otherwise the program runs well with ordinary rights.
I hope this helps.

Offline Jeff_Birt

*
  •  1,107 1,107
    • View Profile
    • Soigeneris
Re: Problems getting mach3 to talk to smoothstepper
« Reply #15 on: March 15, 2011, 11:13:04 PM »
I had a customer have trouble using the profiles I supply along with my drive boxes. Turns out it was an issue with permissions on that file (we tried 'Run as Administrator first and it did not work.) I even tried setting it so 'Everyone' had full control of the profile and sent it to him again but his PC (Win7) didn't like it. The solution was to go in and change the permissions on the file on his PC.
Happy machining , Jeff Birt
 
Re: Problems getting mach3 to talk to smoothstepper
« Reply #16 on: April 24, 2014, 05:48:39 PM »
Well done WYZARDDOC your solution seems to have sorted out my smooth stepper. I had problems with vista and xp crashing when I selected the smooth stepper plugin. Error messages and no saving of my settings.....until I tried the 5V check box thing. All of a sudden I got a flashing red light to say Mach was talking to the SS. great !

I need to see it hooked up and workig but so far so good.