Hello Guest it is July 19, 2019, 05:28:15 PM

Author Topic: Z-axis problem  (Read 2439 times)

0 Members and 1 Guest are viewing this topic.

Z-axis problem
« on: October 03, 2010, 01:30:00 PM »
Hello,

I have managed to glean the answer to many of my problems from reading through past posts. Now I am having a problem with my Z-axis that I haven’t found an answer to. I have my Z-axis set to automatically zero itself using the touch plate, works like a charm. The DRO zeros itself and the Z-axis travels to +2.5”. I have also installed a USB camera to zero the X-axis & Y-axis, also works like a charm. My problem is that after I zero all axis's and then hit the “Go to Zero” button under the DRO’s the Z-axis will travel upwards until it bottoms out, which throws the Z-axis off, and then it proceeds downward trying to punch through the table. I am assuming it should travel downward to where the bit is at zero above the work piece. Hope this makes sense. Can someone shed some light on this problem or my thinking.

Dan

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Z-axis problem
« Reply #1 on: October 03, 2010, 01:36:14 PM »
Sounds like you have a safe Z set. If you home the machine then safe Z is a great thing as it will rise in Z, move X and Y to zero then move Z down to zero thus eliminating (as much as possible) the chance of hitting any clamps etc.
If you dont have home switches then really you should either set up the safe Z as an incremental move or disable it.
Hood
Re: Z-axis problem
« Reply #2 on: October 03, 2010, 01:49:38 PM »
Hood,
Thanks for the reply. I found the Safe Z setup.
Mine showed a checkmark on Allow Safe_Z moves and Safe_Z in an incremental rise, Safe_Z = 1.
Will unchecking the Allow Safe_Z moves disable it?

Dan

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Z-axis problem
« Reply #3 on: October 03, 2010, 01:53:15 PM »
Yes that will disable it or you could set a smaller incremental move if wished. Problem with incremental moves is you always have to be at least that distance away from you max Z height or it will crash like has been happening.
Best thing is likely to disable now but get a home switch fitted up and then you can use safe Z with machine coords and you will be sure the Z will never hit the buffers when you press Go to Zero.
Hood
Re: Z-axis problem
« Reply #4 on: October 03, 2010, 02:26:44 PM »
Hood,
Thanks for your help ;D. I disabled it as you suggested and all is working as expected now.

Dan ;D

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Z-axis problem
« Reply #5 on: October 03, 2010, 02:37:17 PM »
No probs :)
Hood