Hello Guest it is May 25, 2019, 05:48:32 AM

Author Topic: A axis and Mach3R2.0.005  (Read 5494 times)

0 Members and 1 Guest are viewing this topic.

Offline Chip

*
  • *
  •  2,057 2,057
  • Gainesville Florida USA
    • View Profile
A axis and Mach3R2.0.005
« on: October 27, 2006, 11:56:52 PM »
Hi, Brian

Would you  look at this, posted it at yahoo site, guess Art is Busy.

Thank's Chip

My linner set-up X,Y,Z, 40000 step's 10 002 vel, A 144072 step's ve. 4.9998 all seem's fine.

My A rot. set-up 360 deg. set-up X,Y,Z, 40000 step's 10.002 vel, A 400.2 step's vel 2749.8.

With A Angular rot. MDI Cont. Jog will run A at 2750 vel, Step 360 deg 100 vel, Code run max A vel. 100 very slow ?.

Feed-hold and re-start X ref. Lost.

A Dimater change I see no change in A vel. very slow.

A Rotation in view window will not show rotation except after Stop issued or after A only axis move.

After edit-ing at random Mach will rot re-draw cut path, shut down restart req.

Thank's Chip

Update hear,If FEEDRATE set to 2750 then X will run at max and A will blend to 750 vel.

MDI Step 360 and file run F speed set to 2750, will move properly.

Thank,s Chip

Sorry for all the A axis stuff today, Finely got time to install it and do some testing.

The X and A axis don't move together in view, X first then A.

It appear's that the A axis deg. value, 32.727272 dev. by 10,  3.2727272 is being used as the A dia. for setting size of cut view rather than the value in Setting's page.

The start cutter hight and yellow dashed part sise premiter lines to some ohter value greater also and the cutter changes with Setting's value entered for A axis.

After editing code lost the Rotational view back to linear view with no change's to General Config or Tool  Path setting's.

The only way I have been able to get it back is to change to MM exit re-start change back to INCH mode exit-re-start then rot.-view is again present.

Hear's the code I'm useing

m98 p11 l11
m30

o11;----------------------------one deg. step set at 400.2
g91
g01 x2.5 a32.727272 f1500; 11 equal spaces
g01 x-2.5 a-32.727272
g00 a32.727272
m99
%
o110 ;--------------------step set at 144072 one turn of A axis
g91
g01 x.5 a.090909 f100 ; 11 equal spaces, 1 dev. by 11
g01 x-.5 a-.090909
g01 a.090909 f50
m99
%

Art, hope this help's Sorry for the Headake
Thank's Chip

Re: A axis and Mach3R2.0.005
« Reply #1 on: October 28, 2006, 02:31:24 AM »
Hi,
Try G20 to get back to inches
G20=Inches
G21=mm
Im not too sure about the rest.
Greg
« Last Edit: October 28, 2006, 02:33:56 AM by method13 »
"Ideas have consequence" Ravi Zaccharias
Re: A axis and Mach3R2.0.005
« Reply #2 on: October 28, 2006, 08:34:00 AM »
I think you have like 3 things that you are looking to get fixed... could you please list one and explane what is wrong and we will work on them one at a time :)

Thanks
Brian
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com

Offline Chip

*
  • *
  •  2,057 2,057
  • Gainesville Florida USA
    • View Profile
Re: A axis and Mach3R2.0.005
« Reply #3 on: October 28, 2006, 09:57:51 AM »
Hi, Gerg

Thank's Greg, It's not an issue of INCH/MM though.

It's  when in Rotational view A axis, after editing g-code every now and then the view changes to linear view and the only way I've found to get it back to Rotational view is to, use Config/Select Native Units,  change to MM exit re-start change back to INCH mode exit-re-start then  Rotational -view is again present.

This has happened on two computers

Best. Chip

Offline Chip

*
  • *
  •  2,057 2,057
  • Gainesville Florida USA
    • View Profile
Re: A axis and Mach3R2.0.005
« Reply #4 on: October 28, 2006, 06:02:16 PM »
Hi, Brian

Some of this may seem pettie some is not, it makes for a Better Mach3 and is only to point out item's

One at a time is fine although some probably inter-mix, there are more than 3.

1. When using A axis with X, Y, or Z, and  Feeshold,  A and other Axis lose Position on Restart. Lin. or  Rot. Mode.

2. Deleted

3. A axis and X axis don't rotate together in view, earlier ver. thy did. ?

4. Deleted

5. Deleted

6. With  Config ToolPath Reset Plane ond Regen checked it doesn't reset view Plane to straight on view as I though it should, Should It ?.

7. Cut View Blank and or Re-set's Rotational to Linear View.

I've had this happen  quite a few time's, It eather happen's after Editing/Saving Gcode or when using Regen Tool Path, This always requires Re-Start of Mach to resolve, Hopping item 3. has fixed this.


8. Table Display Mode, Spindle object seem's to size with soft limit's , can it be sized to some ratio of object being cut, same as the tool:view.

Thank's Chip
« Last Edit: October 28, 2006, 08:07:28 PM by afn09556 »

Offline Chip

*
  • *
  •  2,057 2,057
  • Gainesville Florida USA
    • View Profile
Re: A axis and Mach3R2.0.005
« Reply #5 on: October 29, 2006, 03:13:34 PM »
Hi Art, Brian, and All

I went back and reinstalled Mach3R2.0.005 in a sub/dir Mach3R2.0.005 clean install once more, configured for rotational A axis as follows.
Config - General Config - checked A-Axis is Angular,  checked - Rot 360 rollover, checked - Ang Short Rot an G0.
Config - ToolPath Configuration - checked - A Rotations Enable, use Diameter for Feedrate.
Config - Ports & Pins, for 4 axis and MPG# 1
Config - Motor Tuning, My A  Rotational set-up 360 deg., set-up X,Y,Z, 40000 step's, 10.002 vel,  A 1 Deg.=, 400.2 step's,  2500 vel, 144072 = 360 1 turn.
Re-Start, Mach3

Loaded Tooth1.txt Gcode file, No Rotational View Shows in Tool Path Window's, just linear view..
Regen Tool Path, Still No Rotational View, Gcode Shows Run Through, Jog A axis shows Degree Mode in Display.

Setting's Page, set Rotation Diameters A axis to 1.0000, Re-Gen ToolPath, OK, Now it shows Rotational View.

Default Start-up and Create New Profile or Closing Mach3 with a value of 0.0000 in the Setting's Page, Rotation Diameters on re-start will Default back to Linear View as it is now.

Could a little-bit of code be added some-where, If ToolPath Page is set to Rotational, Even If Setting's Page, Rotation Diameters are set to 0.0000 to Default to Proper Rotational View..

The answer, Sure no problem, I hope.

I now, why didn't you say this in the first Place, still having some problem's with, Getting a Tool Path Showing Just Yellow Dash-ed Box snowing size for View Tool Path Window's, usually after Editing Gcode, Clicking View Screen for straight on view or Re-Gen of ToolPath, even before the A axis install.

I've spent several day's off & on with all of this, You no the Guy with the Cave-Man Gcode missing in Mach3. 

Just trying to take a tooth-pick out of the gear-train hear, every-once-in-a-while.

Best Regards, Chip
Re: A axis and Mach3R2.0.005
« Reply #6 on: October 30, 2006, 07:52:16 AM »
It will do that if you have the program set up with the center of the part as Z zero. If that is not true then we have no idea how large to make the display :(

Sorry
Brian
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com

Offline Chip

*
  • *
  •  2,057 2,057
  • Gainesville Florida USA
    • View Profile
Re: A axis and Mach3R2.0.005
« Reply #7 on: October 30, 2006, 10:33:18 AM »
Hi, Brian

I understand what your saying, What about a Status or Scrolling massage below Reset Button like,( Rotational Mode Set "Set Radius in Setting's Page") Would give user's something to Que on and cut down confusion.

It caused me quite a bit, There are already so many Nice Feature's in Mach3 like this, probilly not a lot of code, easy for me to say from hear.

If you get a chance could you comment on the other item's hear .

Thank's Chip

Offline Chip

*
  • *
  •  2,057 2,057
  • Gainesville Florida USA
    • View Profile
Re: A axis and Mach3R2.0.005
« Reply #8 on: October 31, 2006, 05:01:47 PM »
Hi, Brian

I may have narrowed this problem down a little, I was using a screen that didn't have a Status window in it.

Cut View Blank

I've had this happen  quite a few time's, It happen's after Editing/Saving Gcode very very random.

In Debug this Run, I get in Status: File Rewind Called

In Normal Run, I get in Status: Display file reinitialized. Error report.

File Load doesn't restore cut view, Close File's and File Load doesn't restore cut view eather

Only Re-Start of Mach3, using ver 2.0.007, has existed for some time.

Thank's Chip
Re: A axis and Mach3R2.0.005
« Reply #9 on: November 01, 2006, 09:25:26 PM »
That is going to be a very hard one to find :(
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com