Hello Guest it is June 27, 2019, 07:05:31 AM

Author Topic: Bugs and comments regarding Mach3Mill v.3.043.022 (current beta)  (Read 3401 times)

0 Members and 1 Guest are viewing this topic.

Bugs and comments regarding Mach3Mill v.3.043.022 (current beta)
« on: September 27, 2010, 10:09:12 PM »
All my notes from a thorough evaluation of the latest Mach3Mill beta, v3.043.022
(Most of this applies to earlier versions too.)
-----------------------------------------------------------
Submitted to: http://www.machsupport.com/forum

Bugs and features in Mach3Mill:
------------------------------------------
Starts up at -2.550, -3.442 instead of 0,0

G80 seems to be ignored.

Disabling X, Y, Z, A, B, C on settings screen only partly disables them. The motion is reduced to 1/10th. Under certain conditions.

G97 is not documented anywhere, yet it shows up at the screen top.

Loading a file resets much less than it should. Keep the machine coordinates, but everything else should go to defaults.

Mach3Mill burns 50% of CPU cycles before the program file is even loaded. Ideally, when the program is not running, CPU usage should be near zero.

It would be nice if the Open File window would find .ngc (EMC and KMotionCNC) and .nc files in addition to .tap files.

Metric/English unit confusion:

   G20/G21 changes the active display -so the operator can't be sure what they are seeing. No indication -other than tiny g20/21- whether units are English or metric.

   Jog doesn't work right. Sometimes it just goes dead and is unresponsive, the a minute later starts working again. In metric mode, the units are all botched.

   Substantial rounding error:
      x1 goes to 0.9906
      x.012 goes to 0.0
      x.013 goes to 0.0254
   If internal state gets set wrong, even G20 will not fix this.

Tab key: MPG is not pulled out as far as it should be (right half cut off). Sure, it can be repositioned, but why not get it right the first time?

Load scorpion.tap file. Repeatedly click "Regen. Toolpath" button. Sometimes the image disappears completely. Doing "Cycle Start" runs, but the image doesn't reappear. The Tool Path screen shows the program limits are all +/-9999.0000

Hold left mouse button in toolpath window. As image is tilted, it partially disappears. [Seems to be an issue just on my computer -video driver?]

The roadrunner.tap file seems slightly corrupt -there are spaces and nulls at the end of the file and there is no ending M30 code.

The Cross.tap file has a strangely sunken eye orbit.

Typos on G-code tables:
   Length is misspelled as "lenght" several places. (i.e. H Tool lenght)
   Non-uniform capitalization (i.e. N line number)

Known issue: Entering values in dialog boxes are not saved unless the enter key is explicitly pressed.

Focus is not given even when the G-code window is scrolled.

No way to see what the internal "set next line" is set to.

Clicking "Zero X" when in "Machine Coords" zeros X without any indication.

Input box not greyed out when in reset mode.

Cannot scroll code window when Single BLK is active.

Clicking Reset turns off Single BLK mode.

ESC does not toggle Reset, like the documentation states.

If Machine Coords is on (Program Run and MDI screens): The Diagnostics screen will show the Current Position as the Machine Coords and the equations will be wrong.

I have seen where subroutines were completely ignored, however I couldn't reproduce that problem.

If a carriage return (^M, space, ;, etc.) is missing after the Onnn line in a subroutine, the subroutine will be ignored! (i.e. if a LF immediately follows the 'O' line, the line is ignored.)

Highlighting in wrong place in subroutine calls -see file.

Last line in file ignored if not followed by a carriage return. Very bad if this line is M99.

Doesn't stop on M1 -not even predictable. It stops, but a few lines ahead due to buffering.

"Reset" button is mislabelled since it doesn't reset anything. Should be labelled "STOP".

It would be nice to use 'mouseover' to give context-sensitive information.

Jog could be done with the mouse and arrows.

The diagnostics page should show more internal states/variables.

When in run mode, the only thing which should accept user input on the "Program Run" (Operate) screen should be Feed rate and Spindle speed override.

All comments are displayed in the "Status: " bar, not just (MSG...) ones.

A non-existent subroutine does not cause an error, it may hang Mach3 though.
(i.e. Calling P0 when P0 does not exist)

G81/G82/G83 do not give errors when X, Y, and Z are missing. G83 takes forever...

Axis inhibits will prevent "GOTO ZERO" from moving, but do not stop the MPG MODE jog buttons from operating.

Stopping/restarting an executing program looses lines -apparently a cache buffer being flushed.

Clicking "Mach3" (to run it) is sometimes ignored if you just closed Mach3. It takes a few seconds to actually stop running, sometimes. Clicking again will run it.

The purple lines showing the current tool position get confused sometimes.

Mach3 is confused about whether it is in G0/G1 mode sometimes, this is shown in the plot window. Will do G1 even when G0 is displayed at the top mode line. Also, the display plot shows the wrong line type.
Doing a Cycle Start will (sometimes at least) set the mode line to show "G0" even though it is still internally operating at G1.

Can't reproduce, but have seen: Clicking "Zero X" will zero X, but change (not zero) Y too.

Have not yet pinned down: Loading the Roadrunner sometimes shows one, not 3 roadrunners.

Soon to figure out: Cross.tap stops after drawing an eye. Only special circumstances.

(+) and (-) keys not inverse. [May have been fixed in current version.]

Offline Hood

*
  •  25,847 25,847
  • Carnoustie, Scotland
    • View Profile
Re: Bugs and comments regarding Mach3Mill v.3.043.022 (current beta)
« Reply #1 on: September 28, 2010, 03:20:53 AM »
Dont have much time to read fully but have looked through quickly and responded to some.

Starts up at -2.550, -3.442 instead of 0,0

I presume you are meaning X and Y coords here? If so then it depends what you have set up, if you choose to have DROs persistent then it will show what you had when you shut down. There are other optyions and can be found from Config menu then General Config page.


G80 seems to be ignored.

Please give an example

Disabling X, Y, Z, A, B, C on settings screen only partly disables them. The motion is reduced to 1/10th. Under certain conditions.
Not sure what you mean by this, can you be more specific in how you are disabling the axis? And what are the certain conditions?

G97 is not documented anywhere, yet it shows up at the screen top.
G97 is mainly a Turn feature, it sets the S word to RPM rather than G96 which is surface speed, it is mentioned in the turn manual.

Loading a file resets much less than it should. Keep the machine coordinates, but everything else should go to defaults.
Your G Code should contain all of the options you want rather than relying on Mach doing it as Mach doesnt know what YOU want as a default. Again General Config has options for this.

Mach3Mill burns 50% of CPU cycles before the program file is even loaded. Ideally, when the program is not running, CPU usage should be near zero.
This is a development meant really for testing of the screenset that will be used in Rev4 of Mach. CPU here is about 7% when idle. What specs computer are you using?

It would be nice if the Open File window would find .ngc (EMC and KMotionCNC) and .nc files in addition to .tap files.
It does if you use the drop down box ;)

Metric/English unit confusion:

   G20/G21 changes the active display -so the operator can't be sure what they are seeing. No indication -other than tiny g20/21- whether units are English or metric.
Again an option whether to keep native units or change to chosen.

   Jog doesn't work right. Sometimes it just goes dead and is unresponsive, the a minute later starts working again. In metric mode, the units are all botched.
Sounds like your computer is either borderline of is getting bogged down with something running in the background.

   Substantial rounding error:
      x1 goes to 0.9906
      x.012 goes to 0.0
      x.013 goes to 0.0254
   If internal state gets set wrong, even G20 will not fix this.
Dont have a clue what you are on about here, no rounding errors for me and if its just the display showing that then likely it is your resolution that is course, ie your steps per unit.

Tab key: MPG is not pulled out as far as it should be (right half cut off). Sure, it can be repositioned, but why not get it right the first time?
As you have discovered you can reposition and once set to where YOU want it it will stay that way.

Load scorpion.tap file. Repeatedly click "Regen. Toolpath" button. Sometimes the image disappears completely. Doing "Cycle Start" runs, but the image doesn't reappear. The Tool Path screen shows the program limits are all +/-9999.0000

Hold left mouse button in toolpath window. As image is tilted, it partially disappears. [Seems to be an issue just on my computer -video driver?]
Llikely to be your graphics  and computers specs.

The roadrunner.tap file seems slightly corrupt -there are spaces and nulls at the end of the file and there is no ending M30 code.
You are not licenced so the Demo restrictions apply, one of which is 500 lines of code in Mill.

The Cross.tap file has a strangely sunken eye orbit.
Not sure what you mean here.

Typos on G-code tables:
   Length is misspelled as "lenght" several places. (i.e. H Tool lenght)
   Non-uniform capitalization (i.e. N line number)
What list is this?


Known issue: Entering values in dialog boxes are not saved unless the enter key is explicitly pressed.
That is intended

Focus is not given even when the G-code window is scrolled.
Focus of what?

No way to see what the internal "set next line" is set to.
You enter the line you want to go to in the DRO for Set Next Line. However in Demo mode it does not work.

Clicking "Zero X" when in "Machine Coords" zeros X without any indication.
What do you expect to happen? It is zeroing the DRO and you are pressing the button so you should know what will happen.

Input box not greyed out when in reset mode.
Input box?

Cannot scroll code window when Single BLK is active.
Fail to see the problem with this. You are in single block so why scroll the window?

Clicking Reset turns off Single BLK mode.
as above but again there are options on General Config page, not sure if that is one or not.
ESC does not toggle Reset, like the documentation states.
Documents are old, Mach is coded by one person who concentrates on coding as much as possible.  You can however set up any hot key you wish to operate Reset, this is done via a screen editor.

Ok have to go now but that will maybe answer some of your questions and throw up a few more ;D
Hood
« Last Edit: September 28, 2010, 03:24:33 AM by Hood »
Re: Bugs and comments regarding Mach3Mill v.3.043.022 (current beta)
« Reply #2 on: September 30, 2010, 02:55:45 AM »
Hi,

The cost Vs functionality has to come in here !
Mach is an awesome piece of software, even when compared to the BIG plyers like Siemens, Fanuc, Hiedenhein etc, but then do the comparison again taking the cost into account.

I could nit pick all day too, but I'm too busy getting the best from Mach and making great parts ;-)

ATB
Deker
You can "chop it off" but can't "chop it on"