Hello Guest it is June 26, 2019, 04:57:08 AM

Author Topic: Somethings missing......?  (Read 3047 times)

0 Members and 1 Guest are viewing this topic.

Somethings missing......?
« on: September 14, 2010, 01:46:28 AM »
Aloha  stirling ,Chip,or anyone that can help

I've been off the forum for a while, good to see that the questions and answers never end. By the way thanks
 for the input last time I was here it was the
controller, Testra corp 4x483 Motion control system, my problem was that  moisture got in the box because
of a flooded room, they took it and rebuilt it , and I  was cutting point and clutch covers again  for Harley's and
Honda's also belt buckle's for our local M/C. I am running  Wolverine 3 with Mach 3 with lisence from Art
I thought I had all the codes and files I needed to ressurect my mill. I took a break from tbe mill, when
powered up the comp was dead, the mother board fried and the info on the hard drive was not recoverable, it was
an old comp, but it did the job. I've
 been downloading version  R2 41 of MACH 3 off of Artsoft website that I am familiar with but
 connot seem to get any movement
 on the step motors. I've done config, ports and pins, motor outputs, input output signals, motor tuning, steps
acceleration and velosity, changing the numbers, active, inactive, just no movement, the info was from  a previous install tha I wrote down to recover the mill if needed , but still
 no movement. I remember a window that asked if I want to reset the settings to run Mach 3, but I have not seen
it appear since. I am useing Winxp, emachine with more than the needed specs for running thr program and mill
 and it is
only for running the mill no other programs.I have downloaded several versions,no success so I'll use the one I know.
I like XP.I've tried the back-ups I have, still no movement, I run a straight parralell port cable, no crossover.
 The reason I do not construct my own controller with Servos is because the hands don't work very well cause of a
 spinal cord damage years ago, quadrapligia, and sitting in this wheelchair doesn't help, but I manage and I like what I do,
I just want to get back to work, anyone with the answers please I could use the help. I can send  the xml and
dat files that I have and Thanks Arnold


Offline Hood

*
  •  25,847 25,847
  • Carnoustie, Scotland
    • View Profile
Re: Somethings missing......?
« Reply #1 on: September 14, 2010, 02:22:51 AM »
When you jog via the keyboard do the DROs move, if not then check the Jog Control is active and also you have the correct port address set. If not then attach your xml and someone can have a look and see if there is a problem.
Hood.

Offline stirling

*
  • *
  •  2,188 2,188
  • UK
    • View Profile
    • www.razordance.co.uk
Re: Somethings missing......?
« Reply #2 on: September 14, 2010, 04:29:21 AM »
Hi Arnold

I reckon Hood's probably on the money with the parallel port address but here's a handy utility for checking out your parallel port. For example with it running alongside Mach you should see the LED activity as you jog back and forth etc.

http://www.geekhideout.com/downloads/parmon.zip

Cheers

Ian
Re: Somethings missing......?
« Reply #3 on: September 14, 2010, 10:12:16 PM »
These are my settings on my comp for Mach 3

My port address is 0x378, kernal speed 25000hz
enabled             step pin#    dir pin#    dir low active            step low active    step port    dir port
X-axis                      3             2               on                         on                       1             1

Y-axis                      5             4               on                         on                       1             1  

Z-axis                      7             6               on                         on                       1             1

E-stop enabled         1            15              on  

enable1   on        port#1      pin#2                                        on

Output#1           port#1      pin#16                                       on
Output#2           port#1      pin#17                                       on

                  Motor Tuning0
            steps per           velocity        acceleration                          
X-axis-     4000                  60                 20
Y-axis      4000                  60                 20
Z-axis     12000                 50                 10
                                                                                
These are the settings from Alignrite via Don

When I press the directionals on the key board and jog, the DRO's move but no movement on the step motors, I am aware that the settings are in the XML files to run the mill, but it still doesn't move.

I'm not able to post the XML and Dat files I have, don't know how to get it to you.  except e-mail                     Arnold
Re: Somethings missing......?
« Reply #4 on: September 14, 2010, 10:28:16 PM »
Testing

Offline Hood

*
  •  25,847 25,847
  • Carnoustie, Scotland
    • View Profile
Re: Somethings missing......?
« Reply #5 on: September 15, 2010, 02:28:09 AM »
You have Enable and Z Dir as the same pin, also you have pin 6 used for X Dir and MPG1 (MPG is an Input) and you are also sharing Pin 15 for MPG1 and MPG2, they all need to be different. You also have Port 6 for MPG1 B channel, needs to be set to Port1
Is the port address correct, if using the on board port it is likely to be correct but check in device manager to make sure.
Hood