Hello Guest it is January 25, 2020, 02:24:05 PM

Author Topic: toolpath veer off axis and continues but off course  (Read 3475 times)

0 Members and 1 Guest are viewing this topic.

toolpath veer off axis and continues but off course
« on: September 13, 2010, 02:30:53 PM »
Hello, I am encountering an error on milling multi-curve job,  from the morning I would start my milling and at about 30-35 minutes the screen on mach shows the toolpath going as programed but on the mill itself the milling is off course on the x and y axis. the program continues and not stop but its milling the wrong location of the stock, after this happends i would have to zero my stock again, and as i keep continuing the program to mill from the error point, the milling time become shorter and shorter for exp. 30 minutes and restart and 20 minutes and restart then 15 or so minutes of milling time. I've been working with the company who sold us the mill and we've done almost every possibility of switching around the axis and still doing the same thing. changed out the PC and same thing occurs. I've been suspecting the controller but cant get them to send another one to test even on our dime. can some one please help direct me out of this?

thank you in advance...

Kunekame
Re: toolpath veer off axis and continues but off course
« Reply #1 on: September 13, 2010, 02:55:31 PM »
have you tried a dry run with the spindle off to see if the steppers are creeping out of position, by either listening for the odd clunk or putting a clock (dti) on the axis.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: toolpath veer off axis and continues but off course
« Reply #2 on: September 13, 2010, 02:57:09 PM »
Replied to your other post but basically it sounds like you are losing steps so maybe try a wider pulse or even sherline mode.
Another thing to check is that your drives are not getting too hot as the decreasing time would seem to suggest heat could be an issue.
Hood
Re: toolpath veer off axis and continues but off course
« Reply #3 on: September 13, 2010, 06:57:52 PM »
Thanks for the info Hood, Im fairly new with Mach3, could you please help direct to changing the settings you suggested.

thank  you
'Kunekame
Re: toolpath veer off axis and continues but off course
« Reply #4 on: September 13, 2010, 06:59:55 PM »
@ angel tech... thank you also.. I will try that.

Kunekame

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: toolpath veer off axis and continues but off course
« Reply #5 on: September 13, 2010, 07:12:56 PM »
The pulse width is set on the motor tuning page (Config menu then Motor Tuning) It says you can set 0-5 but you can actually go as high as 15 if my memory serves me right.
If that doesnt help then you could try sherline mode which gives you a very wide pulse, 40uS I think, you will get that from Config menu then Ports and Pins, its on the main page.
Hood
Re: toolpath veer off axis and continues but off course
« Reply #6 on: September 13, 2010, 10:33:05 PM »
Thanks Hood for the info, I've tried both settings and the mill still veers off course  with lower time of mill. Milling time shorten as i keep contiinuing job. I also tried what teh seller told me to do which was to set the Debounce interval” to 5000 which i had at 200 and that also didnt work. Im running a F1200 high speed Mill by Wabeco, I've suggested to seller to send another controller to test but he insist its not the controller. we'll see what he says from here, thanks for all your help, if you come across another suggestions on settings please let me know

aloha

Kunekame

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: toolpath veer off axis and continues but off course
« Reply #7 on: September 14, 2010, 02:17:41 AM »
Can you blow a fan onto the drives in the controller to see if that helps?
Hood
Re: toolpath veer off axis and continues but off course
« Reply #8 on: September 14, 2010, 04:11:46 PM »
Hi Hood...
thanks for the advise on the fan, Im just about finished with this test with the fan blowing on the drives, opened up teh controller cover and seems to be fine, its been about an hour now and still milling good, usually bogs out at about 1/2 hour. thank you for the awesome help.

Kunekame

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: toolpath veer off axis and continues but off course
« Reply #9 on: September 14, 2010, 04:39:07 PM »
Hopefully thats all it is, certainly sounded like it was a heat issue as the time before problems was getting shorter and shorter, so heres hoping :).

Hood