Hello Guest it is July 19, 2019, 06:54:02 AM

Author Topic: Switched out my PC and now Mach3 is unhappy  (Read 12642 times)

0 Members and 1 Guest are viewing this topic.

Switched out my PC and now Mach3 is unhappy
« on: August 13, 2010, 10:46:02 PM »
I had a very old computer running my Mach setup. It had an Asus based motherboard. Someone donated a fairly decent looking Dell to me that had much more horsepower than my old Asus. It is a Dell Dimension 4600. I did a fresh install of XP on it then immediately installed Mach3. After setting up the pins/motors I get the most horrible noise from my steppers when moving any axis. The motors are stuttering and binding. I plugged my rig back into the Asus based machine and it works well. I even copied the setup XML file from the Asus to the Dell to make sure all the settings were valid. I checked BIOS and set port to EPP. Now I have run out of ideas and need some guidance please. Anyone out there experience this phenomenon on a Dell Precision?

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Switched out my PC and now Mach3 is unhappy
« Reply #1 on: August 14, 2010, 04:55:01 AM »
Try the optimisation steps outlined on the downloads page and see if that helps.
Hood
Re: Switched out my PC and now Mach3 is unhappy
« Reply #2 on: August 14, 2010, 09:57:04 PM »
I did the opto procedure with another fresh install of windows Xp home and the Dell PC acted exactly the same. The motors sound very bad, almost as though they are straining. The max speed cannot be set above a crawl of the motors crash and buzz in one spot. It almost sounds like the direction pins are not remaining on long enough or the pulses are too short. I tried setting the pulse duration to 5 and no change. Is the Dell Precision parallel port compatible?

Offline budman68

*
  • *
  •  2,360 2,360
    • View Profile
Re: Switched out my PC and now Mach3 is unhappy
« Reply #3 on: August 14, 2010, 10:02:08 PM »
So you've disabled ACPI and it had no effect at all?

Thanks,
Dave
----------------------------------------------------------------------
Just because I'm a Global Moderator, don't assume that I know anything !

Dave->    ;)

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Switched out my PC and now Mach3 is unhappy
« Reply #4 on: August 15, 2010, 02:32:37 AM »
Some computers just will not run Mach via the parallel port, I believe it may have been a Dell that Rich had and tried just about everything and still couldnt get it to work. His had, if I remember, a tick tick sound as the motors rotated, is yours similar?

Few things you could try,
If its onboard graphics get an addon graphics card.
Try a PCI parallel port

Hood
Re: Switched out my PC and now Mach3 is unhappy
« Reply #5 on: August 15, 2010, 10:11:03 AM »
Yeah ACPI is not enabled. This was very evident when I went to shut the PC down and now it gives me the message "It Is Now Safe To Turn Off Your Machine". When I did the previous frresh install of XP Home without disabling ACPI it would shut down all the way.

This is best way that I can describe the sound. Imaging a stepper making attempting to make a full step but at the last few microseconds of its travel I try to reverse direction. Almost like that saying "take two steps forward and one step back". When the motors are crawling they appear to work but do not make that sweet low pitch whining noise. If you ramp the speed up to even midrange there is no nice whining but some serious stuttering. This is not even half the rated speed of a stepper. On my other computer with the exact same settings the motors purr along like little kittens. On the Dell it sounds like a bunch of bulldogs fighting.

I do not use the onboard video. It is disabled and I have a beefy ATI AGP card in there.

So my alternatives are getting a new PCI Parallel Port? Is there a USB solution that will work? Any recommended, known foolproof PCI cards that I should be looking for?

As a longshot is there any driver chip on that main board that I could desolder and install a better one or is that functionality built into the southbridge chipset?

Thanks for the help.




Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Switched out my PC and now Mach3 is unhappy
« Reply #6 on: August 15, 2010, 10:16:12 AM »
First thing is if you have not already looked, see what the driver test looks like.

As for USB then there is the SmoothStepper, it does the pulsing so should solve your bad pulsing issues.There are a few things such as backlash comp that the SS does not do yet so be aware of that if you choose to go down that road.
Hood

Offline docltf

*
  •  353 353
    • View Profile
Re: Switched out my PC and now Mach3 is unhappy
« Reply #7 on: August 16, 2010, 11:36:55 AM »
when you change to standard pc that is what happens to the shutdown with xp.also you cant go back to apci without reinstalling windows.
have you played with the pulse width for the motors? have you tried sherlin mode?

bill

Offline simpson36

*
  •  1,374 1,374
    • View Profile
Re: Switched out my PC and now Mach3 is unhappy
« Reply #8 on: August 18, 2010, 08:37:22 AM »
It may well be the built in parallel port. The computer I am using now has similar behavior if the built in parallel port is used at anything over 25K driver speed.

A MACH3 compatible dual PCI parallel port solved the issue completley for me. I posted here a while back the exact card that I am using, source for the card, where to get the drivers, etc. Just do a search and it should show up.  My computer tops out at 86K pulse rate, but the card seems to handle it fine. I run stable at 75k.

The card as I recall is something like $15 or less.
Re: Switched out my PC and now Mach3 is unhappy
« Reply #9 on: August 20, 2010, 09:07:40 AM »
Well I have concluded that the Dell printer port is real crap. I decided to take the computer in my study and swap it with the Dell. I will now use it as my controller. That PC is built around another Asus motherboard. Without having to do any optimization that machine runs my steppers flawlessly. This is not an endorsement for Asus but lets face it this will be the third Asus machine I have moved Mach to and they always run right. Sorry Dell but you lost my future business.

Thank you to all for your input but I think I got this problem solved now.