Hello Guest it is October 23, 2019, 10:43:34 PM

Author Topic: Warning: MSM Macropump appears to have stopped running.  (Read 8332 times)

0 Members and 1 Guest are viewing this topic.

Offline Fastest1

*
  •  927 927
  • Houston, TX
    • View Profile
Warning: MSM Macropump appears to have stopped running.
« on: August 09, 2010, 08:36:59 PM »
I am not sure why it throws this error. I see you reference it in the manual but no fix. I am sure it is something I did.
I want to die in my sleep like my grandfather, not like the passengers in the car! :-)

Offline Fastest1

*
  •  927 927
  • Houston, TX
    • View Profile
Re: Warning: MSM Macropump appears to have stopped running.
« Reply #1 on: August 09, 2010, 09:17:44 PM »
I see V4 is coming out tonight and that it possibly addresses this concern. I dont seem to remember this error. I have not actually cut anything on these screens yet.
I want to die in my sleep like my grandfather, not like the passengers in the car! :-)
Re: Warning: MSM Macropump appears to have stopped running.
« Reply #2 on: August 09, 2010, 09:30:57 PM »
The root problem is a bug in Mach 3.43.10 (and .12) - I did what I could to make it less probable in MSM, but I can't fix it in MSM.
Beta 4 will not remove this particular problem as it's a Mach issue. I think Brian has fix for this - but he has not released a Mach development rev with it fixed yet.

Dave



Author of the MachStdMill Extensions for Mach3
www.CalypsoVentures.com

Offline Fastest1

*
  •  927 927
  • Houston, TX
    • View Profile
Re: Warning: MSM Macropump appears to have stopped running.
« Reply #3 on: August 09, 2010, 09:34:45 PM »
Should I turn off the watchdog in general config til then?
I want to die in my sleep like my grandfather, not like the passengers in the car! :-)
Re: Warning: MSM Macropump appears to have stopped running.
« Reply #4 on: August 09, 2010, 11:15:15 PM »
Alas, that won't matter - the mach watchdog it is not what is generating the messages.
MSM has it's own watchdog which is generating the messages.

If this is happening regularly, there is nothing to be done until Brian makes a release with the fix to the bug in Mach.
I opted to have the messages as being better than allowing a user to run a machine and not realize that part of the system had gone dead.

I would appreciate some data:
1) Are you running other any other apps while mach is running?

For beta 3, Mach is killing the background process for MSM anytime a loop thru the process takes longer than 150ms.
Whether that happens or not is fairly dependent on what else is running on the system. If you are running other apps, shut them down and see if the problem stays away.

2) What is the CPU speed of the PC running mach?

Dave

Author of the MachStdMill Extensions for Mach3
www.CalypsoVentures.com

Offline Fastest1

*
  •  927 927
  • Houston, TX
    • View Profile
Re: Warning: MSM Macropump appears to have stopped running.
« Reply #5 on: August 10, 2010, 12:57:22 PM »
Dave
I am  running Xp Pro SP3
AMD Sempron 3100+
1.8 GHz  1.25G Ram
Mach3 R3.043.010 @65000hz
MSM 0.3.1_Beta_4
No other apps running that I know of and all 3 of your brains are enabled.
How would I know if other apps are running and or how do I stop them?
Also I do have the contour shuttle pro plug in enabled and configured.
Let me know of anything else I can provide.
                         Thanks
I want to die in my sleep like my grandfather, not like the passengers in the car! :-)
Re: Warning: MSM Macropump appears to have stopped running.
« Reply #6 on: August 10, 2010, 01:08:31 PM »
Thanks for the info.
I'm mostly just curious at this point - I don't have enough data to predict the likely hood of the issue occurring.
We do know what the bug is in mach - once the fix is released, this becomes a moot point as it won't happen anymore.

I'm afraid that you seem to be stuck until Brian gives us a fixed Mach rev.
Brian does have a fix for the PeriodicScript bug already - I've tested it.
I've asked Brian if he would release a dev rev with the MDI vs gcode and periodic script fixes.

Now all we can do is wait.  :(

Dave

Author of the MachStdMill Extensions for Mach3
www.CalypsoVentures.com

Offline Fastest1

*
  •  927 927
  • Houston, TX
    • View Profile
Re: Warning: MSM Macropump appears to have stopped running.
« Reply #7 on: August 10, 2010, 07:09:19 PM »
Dave
I appreciate the opportunity to use and or test a new idea and maybe learn something myself.
Do I need to write Brian personally? Just kidding. I am in over my head already. Is there any harm in trying to run it the way it is? It doesnt seem to stop anything , it just makes a noise every 15-30 seconds.
I want to die in my sleep like my grandfather, not like the passengers in the car! :-)
Re: Warning: MSM Macropump appears to have stopped running.
« Reply #8 on: August 10, 2010, 08:00:47 PM »
When the background process is dead the following screen controls don't respond to user actions and/or don't get updated with current data:
        The MSM Probe Result DROs
   Tooling page:
             parts of the Current Tool Info panel
        the Next Tool info panel
        The TT Browser panel
   The inhibited indication LEDs
and probably some other things.

I hate to see someone using a partially dead control - no telling what that could lead a user into doing.
I know it's a pain, but the best thing to do is wait for a revised mach release from Brain.
(or go back to using 1024 until then).

Dave
Author of the MachStdMill Extensions for Mach3
www.CalypsoVentures.com

Offline Fastest1

*
  •  927 927
  • Houston, TX
    • View Profile
Re: Warning: MSM Macropump appears to have stopped running.
« Reply #9 on: August 10, 2010, 11:20:47 PM »
I am not sure if I was getting this error in the other versions if that makes any difference. Anyway it did look like it has a few possibilities. Tell Brian to hurry.
I want to die in my sleep like my grandfather, not like the passengers in the car! :-)