Hello Guest it is October 23, 2019, 12:09:15 PM

Author Topic: Possible bugs in MSM or MSM when used with Galil card  (Read 4063 times)

0 Members and 1 Guest are viewing this topic.

Possible bugs in MSM or MSM when used with Galil card
« on: August 09, 2010, 12:40:25 PM »
I'm not sure, but there appears to be a few bugs in MSM or R3.043.012 of Mach3.  I am running Mach3 with the Galil plug-in,

1.  If I enter any command in the MDI window, it does a cycle start.  This is very scary if a program is loaded.  The program starts and the machine takes off.  I installed a clean version of MSM and R3.043.012 on another computer and it also flashes the cycle start button when a command is entered in MDI.

2.  After finding this, I made sure there was no program loaded and entered the spindle command string M3 S1500 in MDI.  This will start the spindle at the correct speed and direction, but the spindle stops after about one second.  I can manually start the spindle with the CW or CCW buttons.

3.  When I run an edge finder to verify my vice location at offset G54, Mach3 forgets its absolute position, the softlimits are no longer accurate, and it is easy to run the machine into a limit switch.

4.  One really weird problem is if I run the NewFangled linear hole pattern wizard: the X, Y, incremental, and angle input windows display unstable numbers.  I believe the other wizards function normally.

I did not find any of these problems with the standard Mach3 R3.042.40. 

Having said all the above, I think the MSM screen set is very nice and I like its logical set-up.

One request is to add a NewFangled Wizard button to the load screen.  I miss that one.

Thanks,

Jim
Re: Possible bugs in MSM or MSM when used with Galil card
« Reply #1 on: August 09, 2010, 01:14:39 PM »
Hi,

Please review the sticky topic re mach versions and MSM at
http://www.machsupport.com/forum/index.php/topic,15471.0.html

Mach 3.43.12 has multiple problems.
Mach 3.43.10 does not have the MDI/Cycle start problem.

If the issues occur with 3.43.10, the next step in testing is to try those actions with 3.43.10 and 1024.
If they happen on 3.43.10 and 1024 then we bounce it to Brian as a mach package bug.
If it only happens on 3.43.10 AND MSM, I'll go digging a bit deeper - but please understand that I"ll be pretty limited in what I can do as I don't have any Galil the equipment to trouble shoot with.

Dave

« Last Edit: August 09, 2010, 01:20:55 PM by DaveCVI »
Author of the MachStdMill Extensions for Mach3
www.CalypsoVentures.com
Re: Possible bugs in MSM or MSM when used with Galil card
« Reply #2 on: August 09, 2010, 01:25:21 PM »
Thanks for the quick reply.  Can you send me a link to download 3.43.10?  I'll give it a try.

Jim
Re: Possible bugs in MSM or MSM when used with Galil card
« Reply #3 on: August 09, 2010, 01:58:05 PM »
mach download page is at:
http://machsupport.com/downloads.php

near the top of that page, just under the "Downloads" header it says "click here" - that takes you to the FTP archives for earlier versions.
you'll find 3.43.10 in the Mach folder.

Dave
Author of the MachStdMill Extensions for Mach3
www.CalypsoVentures.com