Hello Guest it is November 20, 2019, 01:31:04 AM

Author Topic: limit switch triggered  (Read 14552 times)

0 Members and 1 Guest are viewing this topic.

limit switch triggered
« on: August 03, 2010, 09:52:20 PM »
Hi members,
I have a small problem  with a limit switch error, A short time after the cnc router starts it goes into emergency mode telling me a limit switch has been triggered. No limit switches have been triggered or emergency switch can anyone help please.
Thanks
Regards
Bernie Byers

Online Tweakie.CNC

*
  • *
  •  8,003 8,003
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: limit switch triggered
« Reply #1 on: August 04, 2010, 01:46:46 AM »
Hi Bernie,

This is often caused by electrical noise being picked up on the limit / homing / estop cables and wiring. Others have reported sucess by adding a 0.1uf miniature capacitor between every input and ground (at the controller end).

Screened / shielded cables (grounded at the controller end only) should also resolve the problem.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: limit switch triggered
« Reply #2 on: August 04, 2010, 03:39:11 AM »
Thanks tweakie,
I will try the condenser I have screened cables from the micro switches, but I earthed them one end of each to the frame of the router. I will change them to be earthed at the controller and see what happens.
Best regards.
Bernie

Offline Fastest1

*
  •  927 927
  • Houston, TX
    • View Profile
Re: limit switch triggered
« Reply #3 on: August 05, 2010, 09:36:00 AM »
Do you mean the shields are connected to the machine and the controller? If they are connected at both sides this will be the cause. This is where optoisolation or electrical isolation between your computer and machine would have been bypassed. Also make sure your limit switch wiring is not bundled together with power or stepper wiring. This can lead to false triggering also, from induction I think is the term. The debounce interval in the general configuration page can be lengthened to say 1000 as a test. If that helps start lower it to 500 and less. The way I understand that option is that it only triggers if the signal is constant for the specified period of time, if it is fluctuating during that period it would be disregarded as noise. I know the debounce circuit was disabled for something and I cant remember what it was. Someone will chime in if so. Anyway try lengthening the debounce interval dont worry about the spindle debounce as it is for rpm feedback.
« Last Edit: August 05, 2010, 09:40:12 AM by Fastest1 »
I want to die in my sleep like my grandfather, not like the passengers in the car! :-)
Re: limit switch triggered
« Reply #4 on: August 05, 2010, 11:28:11 AM »
Adding the ceramic caps fixed my phantom limit trigger issues like a charm, I haven't had a false trigger since.  Mine are still just in as a test but will be incorporated into the bob soon.  Add one leg of the ceramic caps (one per lead) to your bob and then tie the other ends together and ground it.  If that works, then add it permanently somehow.  I would be willing to bet this will fix it for you.
Re: limit switch triggered
« Reply #5 on: August 05, 2010, 06:13:30 PM »
Thanks  Tweekie-Fastest1 and Ezcyclone for your answers,I have the screened wirers earthed at one end to the frame. I connected a .1mfd cap across the limit and stop switch terminals on the Bob as suggested  this fixed the problem straight away. I noticed that when the limit switch trigger error happened the led on the diagnostic screen didn't flash this made me think it was some other fault.
Thanks again
Bernie Byers
Re: limit switch triggered
« Reply #6 on: August 06, 2010, 06:31:22 PM »
the cheap ceramic ones work so well, and are sooooo cheap.
Re: limit switch triggered
« Reply #7 on: August 06, 2010, 07:14:38 PM »
Thanks angel tech,
yep i used ceramic ones.
Regatds
Bernie
Re: limit switch triggered
« Reply #8 on: August 10, 2010, 04:53:34 AM »
Re: limit switch triggered
« Reply #9 on: August 11, 2010, 02:47:15 AM »
Hi Angel tech,
Thanks again for your input, haven't had any trouble since i followed your first suggestion. As I mentioned before I put a .1 cond across the limit switch on the c10 and one across the estop terminals. saves me more hours
 of frustration
Best regards
Bernie.