Hello Guest it is May 21, 2019, 03:24:53 PM

Author Topic: Newest ver 3.42.12 running without cycle start.  (Read 3407 times)

0 Members and 1 Guest are viewing this topic.

Offline Mc2

*
  •  31 31
    • View Profile
Newest ver 3.42.12 running without cycle start.
« on: July 31, 2010, 09:35:12 AM »
I have loaded the newest ver. of Mach3 and am now having issues. I have tested this on two computers and ruled out the smooth stepper. When I load a program and the go into MDI mode, I type in G0X0, the program starts to run. Not good. Has anyone else had this issue? I guess I will need to install an older ver.

thanks, Jim.

Offline BR549

*
  •  6,865 6,865
    • View Profile
Re: Newest ver 3.42.12 running without cycle start.
« Reply #1 on: July 31, 2010, 09:59:48 AM »
I can confirm that it does it here as well. Ver 3.43.12
(;-)
Re: Newest ver 3.42.12 running without cycle start.
« Reply #2 on: August 01, 2010, 12:56:33 AM »
This was a bug in versions of mach 3.43.x before .10 - we held up the start of MSM beta until the fix was available in 3.43.10. 

Am I correct in assuming that you are using the standard 1024 screen set when this happens?

It would be real helpful if you would please see if 3.43.10 does this for you - it's avail form the archive section of the download page.

Dave



Author of the MachStdMill Extensions for Mach3
www.CalypsoVentures.com

Offline Mc2

*
  •  31 31
    • View Profile
Re: Newest ver 3.42.12 running without cycle start.
« Reply #3 on: August 01, 2010, 10:10:40 AM »
Dave, I re-installed 3.43.10 as you suggested. I didn't have this issue. I am using the standard screen set. I then put 3.43.12 back on. My issue came back. I then with ver 3.43.12 ran Mach 3 with the new millstadard screen set and I still had this issue.

thanks, Jim.
Re: Newest ver 3.42.12 running without cycle start.
« Reply #4 on: August 01, 2010, 12:48:55 PM »
Thanks for the testing.
I'll inform Brian that it appears that the bug has crept back into 3.43.12.

Dave
Author of the MachStdMill Extensions for Mach3
www.CalypsoVentures.com

Offline Mc2

*
  •  31 31
    • View Profile
Re: Newest ver 3.42.12 running without cycle start.
« Reply #5 on: August 01, 2010, 02:17:19 PM »
Thanks Dave, I will be looking for the updated software and install it when it comes out. I quite often input a value into my dro when I am on the edge of my materials. Then I will command the axis to go to it's zero postion. G0X0 as an exaple.

Jim.