Hello Guest it is July 19, 2024, 10:26:46 PM

Author Topic: Phantom limit stop  (Read 7880 times)

0 Members and 1 Guest are viewing this topic.

Phantom limit stop
« on: July 30, 2010, 06:33:48 PM »
Try and try as I might adjusting debounce does not stop this phantom limit signal.  I have tried 500, 1000, 3000, hell even 10000 I still get the random signal. I have hooked up all of my limits to the oscilloscope and tested with everything from 1mv to 5v and time from 10ns to 1sec.  I get nothing no peaks, no random ac nothing. What do I need to do?  It's driving me nuts and ruining my peices.  I have only run a few things as I'm just getting it running and learning it but this sucks, lol.  I have two ports one is the onboard and the other a add on card and all inputs are on the add on card.  outputs are on the lpt 1.  If I disconnect the db25 cables I don't get the limit signal.

Ok folks.  Thoughts?
Re: Phantom limit stop
« Reply #1 on: July 30, 2010, 06:57:51 PM »
not sure if this will help, i used to get false triggers until i put 0.1uf caps to ground on all the inputs.
Re: Phantom limit stop
« Reply #2 on: July 31, 2010, 01:51:14 PM »
But all my inputs are grounded already, I run all my switches nc to ground.  They go high when triggered.  How would a cap from my inputs to ground to anything?  Is there a back EMF pulse that they might filter out?  If so why could I not find it on the oscilloscope?

Anyone else have anything to add to this?
Re: Phantom limit stop
« Reply #3 on: July 31, 2010, 03:45:26 PM »
so are mine, but it cured my false triggers
Re: Phantom limit stop
« Reply #4 on: July 31, 2010, 03:51:31 PM »
Well ok I will sure give it a shot.  I'll report back in a bit.
Re: Phantom limit stop
« Reply #5 on: July 31, 2010, 06:57:35 PM »
Well I tied in 6 ceramic 104's and so far so good.  I haven't run a part yet but just letting the machine sit idle for about 30 minutes or so and so far it's not bounced at all.  I'm gonna run off a RotoZip spindle mount and see how it does.  Will actually be my first real part with the CNC.  Up till now was just a tiny bit of engraving to learn.

Hey real quick, is there a G-code for return to start position of part?  Say I wanted to cut the same part over and over, or to rerun a part that a limit messed up.   It's odd after it would limit and I reset and hit start again it would run but not turn on the spindle, dragging the engraving bit through the wood.  I got to where I would hit the VFD override and the spindle would kick on but then the engraving was off.  I'm guessing this is from loosing steps due to the bit being dragged through the material?


Offline ASC

  •  59 59
    • Automation Systems
Re: Phantom limit stop
« Reply #6 on: August 01, 2010, 11:52:31 AM »
I had the same problem, getting a little noise from the overhead fluorescent and had my debounce up to 1000!   I put in an optoisolator between the parallel port and limit switch, and fed +5v through the limit switch path.  Sorted it right out and now no more noise!
Mr. Creosote
Re: Phantom limit stop
« Reply #7 on: August 01, 2010, 12:25:33 PM »
Yeah that makes sense.  This breakout is one I built without isolation, the other is a C10.  I actually was running my debounce at 10,000!  and still it would randomly hit.  I cut a part lastnight for my router holder and have an interesting issue.  The straight are right on as far as demention, but the circle cut is bigger then in the drawing, why would this be?  It's a full .1 bigger.
Re: Phantom limit stop
« Reply #8 on: July 05, 2017, 04:46:57 AM »
I am having a limit switch triggered error with mach 3. I do not have limit switches on my Taig mill however.
I cannot reset using the reset icon.
I have to go into settings and manually turn off the limits in order to reset.
Now the jog rate is VERY slow but the program and return to Z runs at normal speed.
When I shut down and restart mach 3, the issue is there once again and I have to manually switch off the limits like I did before.

I've never had this issue with my Taig.

Any advice?