Hello Guest it is November 19, 2019, 05:02:58 AM

Author Topic: Auto Zero Is Not Working - Please help.  (Read 4973 times)

0 Members and 1 Guest are viewing this topic.

Auto Zero Is Not Working - Please help.
« on: July 29, 2010, 06:07:36 PM »
I posted this problem before but it is not resolved.

I have version R3.042.029.

When I run "Ref All Home", X, Y and Z are not getting Zeroed.  I believe this causes me to have a problem with Soft Limits when I try to run a program.  When it does not auto zero, I zero out X, Y by clicking on the appropriate button.

I just tried running a job and I got a soft limits error.  I manually run to the size of the job and I am within the limits of the Home/Soft Limits for all Axises.

I have numerous times, turned off Auto Zero and enabled it.  It works for a couple times with out a problem but it then starts to have a problem.

When do I need to do to fix this problem?  Is this a bug in my version?

It appears to be a problem with Y but I now have Z limit set so I will drive through my spoil board.  I do not like running with soft limits turned off.

I wish that the softlimits message would tell you which limit is out.
Thanks.
« Last Edit: July 29, 2010, 06:11:57 PM by SailFl »

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Auto Zero Is Not Working - Please help.
« Reply #1 on: July 29, 2010, 06:22:32 PM »
If you look at the ticker window it normally tells you which axis the warning is for.
Can you attach your xml and I will see if I can replicate your problem here.
Hood
Re: Auto Zero Is Not Working - Please help.
« Reply #2 on: July 29, 2010, 06:28:15 PM »
What is the ticker window?

I will get the file from my CNC computer and post. 

Thanks
Re: Auto Zero Is Not Working - Please help.
« Reply #3 on: July 29, 2010, 06:37:18 PM »
I had to change the name of the file

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Auto Zero Is Not Working - Please help.
« Reply #4 on: July 29, 2010, 07:08:23 PM »
Seems to be working fine here. I have just emulated the Home switches but have done a home move more than 10 times and each time the Machine Coords get zeroed for X and Y.

I will keep testing for a bit and see if I can break it but is there anything else you are doing other than pressing RefAll button? Do you have any Brains/macropump that may affect things? What does the script in your RefAll button say?
Hood
Re: Auto Zero Is Not Working - Please help.
« Reply #5 on: July 29, 2010, 11:11:10 PM »
Nils, Would have emailed but cant right now.

Anyways you have all your inputs and homing going to pin 15 it looks like. Manual states that you will need to home each axis independently and not use RefallHome.

Cut, Copy Paste out of the manual.

4.5.5.4 Home Switches of Multiple Axes Connected Together

If you are really short of inputs to Mach3, then you can OR the Home switches together and define all
Home inputs to be that signal. In this case you can reference only a single axis at a time -– so you
should remove REF All buttons from your screens – and your Home switches must all be at the end of
travel on their respective axes.

I ended up wiring Jimmys independantly, I just have to figure out how to stop the autosquaring for him.
"Sue Sponte"

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Auto Zero Is Not Working - Please help.
« Reply #6 on: July 30, 2010, 02:22:35 AM »
The RefAll does reference the axis separately so having all switches to the same pin is fine. What the manual is meaning is if you reference by moving all (or a combination of) axis at the same time.
Hood
Re: Auto Zero Is Not Working - Please help.
« Reply #7 on: July 30, 2010, 04:33:25 AM »
Hood,

I think I understand part of my problem.  RefAll zeros out MachineCoord's.  SoftLimits is what causes the RealtiveCoords to get zeroed out.

Let me give you more info.  Before I shut my machine down, I have a G59 location that I GoToZ.  X 39, Y 1.5 and Z 0.0.  My SoftLimits is enabled.  When I am ready to work the next day, after the Mach is up and running and the machine is turned on, I hit RefAll to zero out my machine.  Because SoftLimits is on, when the machine homes, besides the Machine Coords zeroing so does the Relative Coords.

What has been happening more recently is that the Relative Coords have not been zeroing out.  Which if I understand correctly would cause me to have a problem with my SoftLimits giving me a problem though I am in a save working location.

What is going on that my Relative Coords are not zeroing out?

And What is the tickler window?

Do I have a correct understand of how things work?

Thanks for your help.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Auto Zero Is Not Working - Please help.
« Reply #8 on: July 30, 2010, 06:17:48 AM »
Ok the normal way of working is you have Persistent Offsets (which you have) and Persistent DROs (which you dont)
Ok so you start Mach and the DROs should show the last position you closed with, you reference the machine and the Machine Coords will zero and the work offsets will change in relation to where the machine was and where it is now.
For example if your X and Y were at 10 and you were actually 20 away from the machine zero then the DROs would say -10 after you home.


Soft limits are in machine coords.

One thing you may find handy is if you change the toolpath view to show table, this will let  you see if your code will be outwith the machines boundaries, if it is you can then jog to a more suitable position and zero the work offsets by pressing the zero button at X and Y  DRO. To get to table view you click the Display mode button and then regen, to get back to work view click it again and regen again.

The Ticker message is the  status window at the bottom of the standard screenset.

Hood
Re: Auto Zero Is Not Working - Please help.
« Reply #9 on: July 30, 2010, 06:47:57 AM »
Hood,

Then what is zeroing the relative x, y and z windows when MachineCoords button is not enabled?