Hello Guest it is October 16, 2019, 06:20:55 AM

Author Topic: Turn off E-Stop  (Read 4848 times)

0 Members and 1 Guest are viewing this topic.

Turn off E-Stop
« on: July 29, 2010, 02:36:20 PM »
I'm not trying to disable the E-stop on a functioning system.

I have two computers.  The one that controls my mill is downstairs and off the network.  It is used solely for Mach3 so I don't run any other programs and don't have it on the network so no virus protection and such is needed.  I use my main computer upstairs to run Alibre and CamBam then transfer the files to the other system with a thumb drive when I'm ready to mill.

I loaded Mach3 on my main computer as I'd often like to step through the CamBam generated code with Mach3 to test it before taking it downstairs.  This system is not hooked up to a mill and I can't seem to turn the E-stop off so I can dry run the code.

Thanks,

Mark

Offline zealous

*
  •  492 492
  • HI!
    • View Profile
    • Artsoft Solutions
Re: Turn off E-Stop
« Reply #1 on: July 29, 2010, 03:17:33 PM »

If your Estop isnt reseting you may need to change the active low setting:

Config/Ports and Pins/InputSignal/
Scroll down to "Estop" and change your Active Low


Either that or turn off softlimits.
Re: Turn off E-Stop
« Reply #2 on: July 29, 2010, 03:44:44 PM »
Found an easy fix.

I set it to emulate with the F1 key.

thanks,

Mark
Re: Turn off E-Stop
« Reply #3 on: July 10, 2013, 01:48:25 PM »
Hi all,
Im new to this forum after buying Mach3 transferring from WIN PCNC-USB.  I used the file Donkeyot posted  to configure my Heiz s1000 and got it to work (thanks, I would have never figured it out on my own) but my Reset keeps tripping.  Has anyone had this and got a soulution or suggestions?  Thanks
Dave

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Turn off E-Stop
« Reply #4 on: July 10, 2013, 04:34:28 PM »
Would seem like you are picking up noise on the E-Stop input. Ideally it should be shielded and properly grounded but as a test you could go to config menu then General Config and enter a value of 2000 in the Debounce Interval area and see if that helps. If it does then get as low as possible on that value.
Hood
Re: Turn off E-Stop
« Reply #5 on: July 11, 2013, 01:45:55 PM »
Hi
Thanks for that, at the mo, I have it down to 100.
regards
Dave

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Turn off E-Stop
« Reply #6 on: July 12, 2013, 09:10:20 AM »
That sounds good, cant be too noisy if 100 is fine :)
Hood