Hello Guest it is June 26, 2019, 04:54:38 AM

Author Topic: new hard drive.  (Read 3020 times)

0 Members and 1 Guest are viewing this topic.

Offline PCH

*
  •  63 63
    • View Profile
new hard drive.
« on: July 23, 2010, 03:54:28 PM »
Got a new system.   Still have old hard drive.  I cannot get Mach to work.   Downloaded software on new system.  I have been try to get my xml to load.  I took a file from the  xmlbackup folderon old harddrive , the latest one & copied and renamed it them loaded into mach directory on new system.  Restared system and no keyboard action.  What am I doing wrong.  I need a step by step to get the mach program that worked on old sytem to work on the new.  Tried driver test and just says runing to fast or something .  What about the parallel cable.  This is frustrating.
Please help >:(

Offline Hood

*
  •  25,847 25,847
  • Carnoustie, Scotland
    • View Profile
Re: new hard drive.
« Reply #1 on: July 23, 2010, 03:59:59 PM »
Dont use the backup, go back to the main Mach3 folder on the old drive and look for the proper xml, it will be named after the profile you were using. If for example you were using Mach3Mill profile it will be called Mach3Mill.xml.
Hood

Offline PCH

*
  •  63 63
    • View Profile
Re: new hard drive.
« Reply #2 on: July 26, 2010, 09:32:47 AM »
Thanks Hood that worked!
The only thing not functioning now is when I am in the midi screen, if I type G0, y0,x0 to return to home it there is no response.
The jog switch is activated.  What can I do?

Thanks, PCH

Offline Hood

*
  •  25,847 25,847
  • Carnoustie, Scotland
    • View Profile
Re: new hard drive.
« Reply #3 on: July 26, 2010, 10:16:05 AM »
Thanks Hood that worked!
The only thing not functioning now is when I am in the midi screen, if I type G0, y0,x0 to return to home it there is no response.
The jog switch is activated.  What can I do?

Thanks, PCH
sounds like you are in Incremental mode (G91) so you are commanding a move of zero.
MDI  a G90 then try your G0X0Y0 again.
Hood

Offline PCH

*
  •  63 63
    • View Profile
Re: new hard drive.
« Reply #4 on: July 26, 2010, 10:28:17 AM »
How do I MDI a G90?

Offline Hood

*
  •  25,847 25,847
  • Carnoustie, Scotland
    • View Profile
Re: new hard drive.
« Reply #5 on: July 26, 2010, 02:30:02 PM »
How do I MDI a G90?

Exactly the same way as you MDI your G0X0Y0, just go to MDI page, enter G90 in MDI window and press enter on your keyboard.
Hood

Offline PCH

*
  •  63 63
    • View Profile
Re: new hard drive.
« Reply #6 on: July 26, 2010, 02:37:04 PM »
Thanks Hood.  It worked!   Is there a way to use the G90 as a default?  I never had to enter that before the g0,y0,x0 to get to home.

PCH

Offline Hood

*
  •  25,847 25,847
  • Carnoustie, Scotland
    • View Profile
Re: new hard drive.
« Reply #7 on: July 26, 2010, 02:47:35 PM »
G90 is usually default but you can go to Config Menu then General Config and choose it to be Abs there for Distance mode. It is however always a good idea to have the first line in all your code setting the parameters that the code should run.  G90 G20 G64 etc etc, that way if a run of previous code has changed to Incremental it will be reset to Absolute, same for metric /imperial (G20/G21) ConstantVelocity/ExactStop (G64/G61) ETC ETC
Hood

Offline PCH

*
  •  63 63
    • View Profile
Re: new hard drive.
« Reply #8 on: July 26, 2010, 03:17:35 PM »
Thanks for all your help.  Guess I need some education on the setup peramiters.  I know there is a file in Mach where you can put these initialization codes in as I have done that with the M30 at end of code run.