Hello Guest it is July 15, 2024, 08:45:49 PM

Author Topic: Home switch set up  (Read 13505 times)

0 Members and 1 Guest are viewing this topic.

Home switch set up
« on: July 22, 2010, 08:18:24 PM »
Hi All,

I am setting up a DMC-2143 with the SDM-2042 stepper driver attached.  No matter how I configure the home switch it won't work(meaning i start homing then trigger the switch and nothing) when using mach3.  It works fine when i am using the DMC Smart terminal.  The switch is recognized and the home cycle completes as normal.  If I try to home in Mach3 the switch is not recognized.  The limits work fine, both settings (active high and low).  I am using the home input on the SDM-2042.  One thing I have noticed is that in the data record of smart terminal, the axis switches for the " State of home input" is not effected by selecting home active low in the plug-in config.

Also are ports and pins setting necessary?  As I am not using a printer port and the limits are working  I am guessing no.

Thanks

Offline kcrouch

*
  •  193 193
  • In way too deep!!!
Re: Home switch set up
« Reply #1 on: July 24, 2010, 12:05:02 PM »
Ports and pins settings are absolutely necessary to communicate with Mach. Please see the PDF manual on the plugins download page.
Kenny
Having way too much fun! Something must surely be wrong.
Re: Home switch set up
« Reply #2 on: July 26, 2010, 08:48:40 AM »
Hi Kenny.

  I followed the input chart in the galil plug-in manual like you suggested and now the lights in the diagnostic page light up correctly.  However I still cannot get the home switch to me recognized when i do reference all home.  Works in smart terminal fine. but in mach the motor just keeps moving and the home switch does nothing(except turn the yellow light on).  I'm not sure what I am doing wrong and what I need to try next.  I tried using the limits for home choice in the plug in and still nothing.  it stops the axis(limit) but doesn't home the axis. 

Should look for something in the debug file?

Thanks for the help.

Offline kcrouch

*
  •  193 193
  • In way too deep!!!
Re: Home switch set up
« Reply #3 on: July 26, 2010, 12:11:58 PM »
By all means, check out the Galildebug file. It will give a wealth of troubleshooting information. Also send mr a copy and I will try to figure it all out for you.
Regards,
Kenny
Having way too much fun! Something must surely be wrong.
Re: Home switch set up
« Reply #4 on: July 27, 2010, 08:35:39 AM »
Thanks,

I have emailed you a copy of the debug file.

Cheers

Offline Shivu

*
  •  18 18
Re: Home switch set up
« Reply #5 on: December 28, 2010, 04:00:02 AM »
Hi Kenny,

I am also facing the same problem which Cheers has got.

Homing works in Smart terminal and in the MACH3 the motor is continually running even if the Home limit pressed.

What could be the Problem.

SHivu

Offline kcrouch

*
  •  193 193
  • In way too deep!!!
Re: Home switch set up
« Reply #6 on: December 28, 2010, 08:02:12 AM »
Shivu,
Have you mapped the switches on the ports and pins screen according to the instructions in the Galil.PDF document? If so, do the switches show up correctly on the diagnostic screen? Also make sure that there are no other identically mapped ports or pins elsewhere as they will conflict. You may have the switch state wrong in Mach. The Mach homing routine is completely different from what you use in Smartterm. Check the debug file for any errors or "?" returns from the Galil board.
Kenny
« Last Edit: December 28, 2010, 08:04:12 AM by kcrouch »
Having way too much fun! Something must surely be wrong.
Re: Home switch set up
« Reply #7 on: December 29, 2010, 10:30:36 PM »
I too have been having the same problem on a retrofit I'm doing. I set the ports and pins for the home switches in Mach3. Mach3 diagnostics show the switches trigger, but Mach sends the machine to the switch, ignores the change of switch state, and keeps going.

My setup is using a Galil DMC-1842, in Servo Reverse mode. Though I am not on-site at the retrofit to test on the machine there, I am suspecting that setting to be the culprit. The reason I say that is this: I brought the control computer back to my shop to test with. I hooked it up in stepper mode to test as I don't have any analog servos at the shop. I did a clean install of mach. Installed the plugin. Configured the plugin, setup my homes and limits (just exactly as I did on-site). It worked! At the moment, I suspect that Motor Type setting in the Plugin Config.

Also, I was told that I should set my limits and homes to identical values (i.e. - X Low Limit and X home are both enabled with the same port and pin configuration). I don't know if that was actually necessary, though. The next opportunity, I will try to determine that.

Shivu, be sure to let me know how you progress on this. This issue has cost me a lot of down time, as it may have you. I hope to resolve it soon.

Thanks,

Josh G.

P.S. - Let me clarify... My vertical axis (z) actually homes correctly, but the axes that home in their respective negative directions do not.
« Last Edit: December 29, 2010, 10:32:14 PM by HighOctane »

Offline smurph

*
  • *
  •  1,548 1,548
  • "That there... that's an RV."
Re: Home switch set up
« Reply #8 on: December 30, 2010, 02:06:38 AM »
-X low and X home enabled with the same pin config is not a good idea.  They are two separate signals in Mach.  So keep them separate.  Map Mach X-- to port 1, pin 9.  Then map Mach X home to port 1, pin 17.  If you use a limit switch also for a home switch, jumper the switch to both the -X and X home on the Galil ICM.  Limits switch signals are disabled when homing!  This is to allow using a limit switch also as a home switch. (Which I really don't know why anyone would want to do, but people asked for it.  Me?  I'm buying a $8.00 switch to do the job...)

The Galil plugin is looking for the Mach home signal to become activated.  It basically does a jog towards the home switch using the Galil JG command.  Say 2000 counts per second.  That would be JGX=2000 to move the X axis in a positive direction as 2000 is a positive number.  If you hit the home switch and then move off before Mach catches the signal (1/10th of a second), then you might have a problem.  If this is the case, you need to rig your switch to stay activated longer.

When Mach sees the home signal get activated, the galil plugin stops the axis.  It then reverses the axis by taking the initial jog velocity and multiplying it times -0.1  So 2000 becomes -200.  So JGX=-200 is sent to the controller.

When Mach sees the home switch go to the inactive state, the galil plugin stops the axis withing 1/10th of a second.  Homing is done at this point unless you have specified the use of the index pulse.  

If using the index pulse, the galil plugin issues the same JGX=-200 jog command until it finds the index pulse from the encoder.

That's the sequence anyway.  If you are blowing past your switch and your are seeing the signal light up in Mach, then there might be an error in the commands going to the controller.  Enable the debug output in the plugin configuration.  This creates a GalilDebug.txt file with the commands sent to the controller and the controller's response to them.  Then repeat your home operation and exit Mach.  This will fill the GalilDebug.txt file with the information from your home operation.  Then find the GalilDebug file (usually in c:\mach3 or c:\mach3\plugins) and send it to either Kenny or Myself.  Our email addresses are in the plugin PDF manual.

Steve
Re: Home switch set up
« Reply #9 on: January 11, 2011, 12:38:04 PM »
Steve,

Thanks for the description of the homing routine. This has proven very helpful. I finally made it back up to the site where the machine is, and I can now get the Y axis to home properly. I simply had to home more slowly as Mach wasn't catching the signal because the home sensor triggered on then off again too quickly.


NOW, another small issue... When I am homing my X axis (to which the A axis is slaved), sometimes the A axis home triggers first, but the X keeps pushing both axes as its home signal hasn't been triggered yet. This sometimes results in a fault of the servo from pushing against its end stop. What is the best way for me to handle that? Should I write a custom home routine, or is there a setting in the galil plugin for this?

Thanks,

Josh

P.S. - would having both of my prox sensors wired to the same X home input do the trick?

P.P.S. - I do have perform axis squaring for slaves checked. How do I tell Mach the value to offset the slave when homing to adjust the gantry into squareness?
« Last Edit: January 11, 2011, 12:41:01 PM by HighOctane »