Hello Guest it is November 18, 2019, 06:13:36 AM

Author Topic: Inhibit Function for input #1  (Read 1886 times)

0 Members and 1 Guest are viewing this topic.

Inhibit Function for input #1
« on: July 20, 2010, 04:12:25 PM »
I am trying to setup the Inhibit functionality in Mach. I have input 1 set to pin 15 of the bob, I have checked the General Config box to Enable the Function, the input 1 led will toggle on and off but the Inhibit led and functionality will not work.  I am trying the use the inhibit function so that my programs will not begin to run unless my charge pump is active. Can anyone point me in the right direction on this?  I have checked the manual but I can't seem to find anything on this that will help.

Thanks,
Tom

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Inhibit Function for input #1
« Reply #1 on: July 20, 2010, 04:25:31 PM »
Should be straightforward thing to do, just the signal to your BOB, Input 1 set to the correct pin and port and the option enabled in General Config.
What version of Mach are you using and if you attach your xml I will test it here. I have just simulated it with a generic xml and it seems to work fine when I emulate Input 1.
Hood
Re: Inhibit Function for input #1
« Reply #2 on: July 20, 2010, 05:51:48 PM »
Thanks, Hood I was able to get it working. the only thing is that the led does not light but it is working.

Tom

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Inhibit Function for input #1
« Reply #3 on: July 20, 2010, 06:37:18 PM »
Good to hear :)

Hood