Hello Guest it is May 19, 2019, 01:02:17 PM

Author Topic: G0 X0 or G0 X0.0  (Read 3004 times)

0 Members and 1 Guest are viewing this topic.

G0 X0 or G0 X0.0
« on: July 12, 2010, 11:25:08 AM »
Hi

New to Gcode programming but I get the following inconsistency.

On the MDI screen sometimes an axis will go to zero whether I use G0 X0 or G0 X0.0 but some it will only work if I input G0 X0.0 and sometime I can only get the axis to move if I use G0 X-0.0

Why?

Brian

Offline ger21

*
  • *
  •  6,231 6,231
    • View Profile
    • The CNC Woodworker
Re: G0 X0 or G0 X0.0
« Reply #1 on: July 12, 2010, 11:49:49 AM »
Sounds like your sometimes in incremental mode and sometimes in absolute mode.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: G0 X0 or G0 X0.0
« Reply #2 on: July 12, 2010, 01:17:38 PM »
Sounds like your sometimes in incremental mode and sometimes in absolute mode.

Hi Gerry

Not changing the settings and why would this be different for these 2 modes anway?

Brian
Re: G0 X0 or G0 X0.0
« Reply #3 on: July 12, 2010, 01:42:57 PM »
Just had a thought Jerry:-)

If I was in Incremental mode then surly no G0X0 would move the axis

What I am getting is, for example

X axis at 4mm, then input G0X0 - nothing moves then input G0X0.0 - axis moves to zero

Brian

Offline ger21

*
  • *
  •  6,231 6,231
    • View Profile
    • The CNC Woodworker
Re: G0 X0 or G0 X0.0
« Reply #4 on: July 12, 2010, 02:05:57 PM »
Are you sure your not typing "O" instead of zero? It shouldn't make any difference.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: G0 X0 or G0 X0.0
« Reply #5 on: July 12, 2010, 02:15:19 PM »
Are you sure your not typing "O" instead of zero? It shouldn't make any difference.

Pretty sure:-)

It's happen quite a few times so I doubt that its finger trouble.

No problems when running a program only happens on the MDI screen

It's not causing me any big problem, I was just concerned that I was misunderstanding how the Gcode works.

Brian

Offline ger21

*
  • *
  •  6,231 6,231
    • View Profile
    • The CNC Woodworker
Re: G0 X0 or G0 X0.0
« Reply #6 on: July 12, 2010, 05:11:20 PM »
Both ways should work just fine.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline RICH

*
  • *
  •  7,330 7,330
    • View Profile
Re: G0 X0 or G0 X0.0
« Reply #7 on: July 12, 2010, 08:28:06 PM »
Brian,
 I don't know what to say as I have never had your problem.
G0X0
G0 X0
G0 X0.0
G0X0.0
They all work......

RICH
Re: G0 X0 or G0 X0.0
« Reply #8 on: July 13, 2010, 03:38:04 AM »
cheers guys

Next time it happens I will try and note what exactly the onditions where. I seem to think it was happening when I had been mucking about with the axis calibration but absolutly certain. :)

Brian