Hello Guest it is January 21, 2022, 03:27:04 PM

Author Topic: Home and limits stopped working  (Read 2460 times)

0 Members and 1 Guest are viewing this topic.

Home and limits stopped working
« on: July 08, 2010, 01:28:03 AM »
Hey guys I have an X3, CNC Fusion, G540, Mach 3 setup. Homing and limits were working perfectly for the past couple of months, then all of a sudden, the switches aren't stopping the machine.

They are, NC, in series, and not showing any yellow trip lites in the Mach diagnostics screen. I tested them with my DMM and all are working fine, I also checked the wires and there is continuity all the way around, I manually actuated the switches and checked that the loop opened.

Is it the G540? I tried another input terminal and still no good. My edge finding probe setup using a cnczone.com member's screen also stopped working at the same time. Or is it something in Mach 3? I've attached my XML.


Offline Hood

  •  25,835 25,835
  • Carnoustie, Scotland
    • View Profile
Re: Home and limits stopped working
« Reply #1 on: July 08, 2010, 03:31:06 AM »
XML seems fine from a quick glance, except I would have expected NC to be set Normally High, but maybe the G540 inverts them?
Even so then it would show limits hit until you pressed them so looks like its not the problem as you dont get any signs of limit activity.
Best bet is to remove the cable from the computer and test directly on the port by shorting out pin 13 to a Gnd pin and see if the limits LEDs change, if they do then its a problem with either cable or G540, if not its then it would seem the port is the problem.
Re: Home and limits stopped working
« Reply #2 on: July 08, 2010, 09:17:27 AM »
Thanks! Yeah, I'm just following others' directions on whether the input is set low or high, but I will definitely try what you suggested.
Re: Home and limits stopped working
« Reply #3 on: July 09, 2010, 01:16:37 AM »
It's alive again!

I wired directly from the G540 to -VDC and still no dice so removed the lead and found that the shielding from my wire worked its way out and was making contact with something. Replaced the wire and went back to the Hoss screen and all is good :-)

I did have to change my settings  to active high. Maybe they were that way before, I vaguely remember forgetting to turn on the control box before starting Mach 3 and got the "do you want to have Mach 3 change the settings for you?" error screen. I probably hit ok, not knowing my wire was rubbing on something.

Thanks for your help!