Hello Guest it is June 24, 2019, 08:25:14 AM

Author Topic: Help with ideas how to get Mach3 working?  (Read 3052 times)

0 Members and 1 Guest are viewing this topic.

Help with ideas how to get Mach3 working?
« on: June 29, 2010, 10:42:51 PM »
Hi,
I have a new (to me) 10 year old Wolverine II mill; 36v, 3A, 1/4 step, SS drivers that came with a computer running Master5. I would like to upgrade to Mach3 and have a computer that meets the specifications for Mach3, WinXP. The demo is installed and for practice runs it seems to work fine. I went through the setup instructions to the point where it says to connect the cable to the parallel port. But I get no response from the mill. I know the mill works because it works with the old computer and Master 5. I feel like there is a setting I have missed somewhere. Does anybody have ideas for me?
Thanks so much, looking forward to getting to know some folks here.
Dwight

Offline Hood

*
  •  25,844 25,844
  • Carnoustie, Scotland
    • View Profile
Re: Help with ideas how to get Mach3 working?
« Reply #1 on: June 30, 2010, 01:48:18 AM »
Could be one of many settings but the first I would check is that you have the port address set correctly.
Hood
Re: Help with ideas how to get Mach3 working?
« Reply #2 on: June 30, 2010, 10:23:46 AM »
Awrite! BIOS and properties list the port as 378. So that is what I used in Ports and Pins. I think I can scounge up an old parallel printer to see if that works with it.
Thanks Hood,
Dwight

Offline Hood

*
  •  25,844 25,844
  • Carnoustie, Scotland
    • View Profile
Re: Help with ideas how to get Mach3 working?
« Reply #3 on: July 01, 2010, 04:06:31 AM »
Can you attach the xml you are using for both Master5 and Mach3 please.
Hood
Re: Help with ideas how to get Mach3 working?
« Reply #4 on: July 01, 2010, 11:02:10 PM »
I'd be happy to if I knew what that was.
Re: Help with ideas how to get Mach3 working?
« Reply #5 on: July 01, 2010, 11:15:43 PM »
ha! I found it and figured out what I needed to do. Thanks,
Dwight
Re: Help with ideas how to get Mach3 working?
« Reply #6 on: July 08, 2010, 12:04:12 PM »
Chack your breakout borad as follows.
apply 5v to the supply pin. Check this supplies both the computer side of the board and the mill side.
connect each output you want to use, say 2, 3, 4, 5, 6, 7 to a led and each led via a 220 resistor to
a rail connected to +5v
then add a wire to the ground terminal.
use this to touch pins 2 3 4 5 6 7 in turn and see if it turns the led off

For mach 3 go to the config window
go to portsd and pins
set port 1 to enable set port 2 to disable
enable output signals 1 2 3 4 5 6 to enable
set port to 1 for these signals
for output  set pin
1              2
2              3
3              4
4              5
5             6
6             7
for pins 2 to 7 set active low

click apply and end?

you will have to go to congig again then select motor outputs

set      enabkle  step pin  dir pin   step pot   dir port

x         yes        2           3          1             1
y         yes        4           5          1             1
z         yes        6           7          1             1

click apply and end

connect board to computer with leds still attached

leds should be on (or off?)

go back to ports and pins and toggle for each pin the active low
doing this should change the state of the led for that pin


john f


Re: Help with ideas how to get Mach3 working?
« Reply #7 on: July 08, 2010, 01:33:22 PM »
Thanks John,
Yes, I see that I needed to get the correct pin orders. Makes all the difference. Got it working now. Thanks,
Dwight