Hello Guest it is May 25, 2019, 09:45:30 PM

Author Topic: Mach 3, wierd infinite feed rate problem  (Read 9986 times)

0 Members and 1 Guest are viewing this topic.

Re: Mach 3, wierd infinite feed rate problem
« Reply #20 on: June 01, 2014, 01:39:45 AM »
rhetorical question
Then who uses Mach3 ?!
is probably the most prevalent software and still has an inexplicable error .

Then
How can i be sure that in my code i don`t have these type of line code.

Plese tell me, how you solved the problem
Is a solution to changed the program to something else
Re: Mach 3, wierd infinite feed rate problem
« Reply #21 on: June 01, 2014, 01:42:55 AM »
I did not solve the problem.  I switched the output from the post processor in the gcode generator to disable helical interpolation.    In general, I do one of the two following...  avoid helical moves at all costs, or if necessary, hand code them/post them separately so I can easily test the code before use.
Re: Mach 3, wierd infinite feed rate problem
« Reply #22 on: June 02, 2014, 03:28:26 AM »
I understand, thanks.
What software for post processor has the function to disabling helical interpolation.
In Solidcam , 3D iMachining operations all process is generated automatically, with few user options, i can not find an option to not use helical interpolation.
Has something like " Classic helical cutting condition" - on or off.
Re: Mach 3, wierd infinite feed rate problem
« Reply #23 on: June 02, 2014, 10:54:20 AM »
Contact your solidcam reseller.   they can modify the post processor for you or try a different default one.  Not all machines have supported helical interp.