Hello Guest it is December 13, 2019, 06:19:34 AM

Author Topic: Mach 3, wierd infinite feed rate problem  (Read 10381 times)

0 Members and 1 Guest are viewing this topic.

Offline ger21

*
  • *
  •  6,291 6,291
    • View Profile
    • The CNC Woodworker
Re: Mach 3, wierd infinite feed rate problem
« Reply #10 on: June 27, 2010, 09:58:45 PM »
I should point out that I have 3.12.040 on this PC. Different versions may behave differently.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Mach 3, wierd infinite feed rate problem
« Reply #11 on: June 27, 2010, 10:01:52 PM »
does it try to instantly change in Z on your version?
Re: Mach 3, wierd infinite feed rate problem
« Reply #12 on: June 27, 2010, 10:34:14 PM »
I may be way off base here, but are you missing a Z move in this line?

G03 X-9.8916 Y-.835 I-9.9155 J-.8588

Then in next line it has to make a straight z move down to get to correct position for start of second half of helix.

Am I full of it?

Seems to me it is doing a flat arc here, not half a helix.

John Champlain
Re: Mach 3, wierd infinite feed rate problem
« Reply #13 on: June 27, 2010, 10:50:58 PM »
yes, something is wrong with the code, and getting rid of the helical interpolation solves it (or fixing the buggered up helix).  the bigger issue is that when you put said code into mach, it tries to make an infinite feedrate Z move...  something that it should in no way be able to do, and I consider a bit of a safety issue, since if it does this wierd "move infinitely fast in z" in response to bad code, (without warning about said code) what happens when it does it some other time and moves/tries to move unexpectedly in a bizzare manner.  at the very least there should be something in the code that prevents it from trying to move faster than the setpoints in motor tuning.

Offline ger21

*
  • *
  •  6,291 6,291
    • View Profile
    • The CNC Woodworker
Re: Mach 3, wierd infinite feed rate problem
« Reply #14 on: June 28, 2010, 07:47:30 AM »
As I said before, I think it's a bug with CV mode. I think it'll be fixed in the next version of Mach3, as it's a very difficult fix. And it very rarely occurs.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Mach 3, wierd infinite feed rate problem
« Reply #15 on: June 28, 2010, 10:42:58 AM »
Greg,

I now have a better understanding of what you have discovered.   It probably is a program bug, but, regardless, it should be impossible.  I was able to observe it in a dry run (router off) at a very slow feed rate.  It is indeed scary, and may help to explain a few of the strange (but rare) behaviors that I have experienced with some of my older gcode routines that I switched from a DOS driver to Mach3.

Perhaps Art or Brian will pick up on this thread and work to help resolve, or at least explain, this issue.

Thank You,
John Champlain
Re: Mach 3, wierd infinite feed rate problem
« Reply #16 on: May 31, 2014, 05:05:31 PM »
Hello
the problem persist, have the same problem with mach3 .
code is as fallows

No solutions ?
Re: Mach 3, wierd infinite feed rate problem
« Reply #17 on: May 31, 2014, 06:09:09 PM »
No practical solution I know of.   
Re: Mach 3, wierd infinite feed rate problem
« Reply #18 on: June 01, 2014, 01:20:06 AM »
haw can we ensure that motor do not lose steps ?
let say we use solidcam, what post proccesor is best for Mach3 ?
Re: Mach 3, wierd infinite feed rate problem
« Reply #19 on: June 01, 2014, 01:22:50 AM »
You can't.  If you run into this error, mach will go to an absurdly impossible feed rate, and crash into whatever is in its way or stall