Hello Guest it is October 22, 2019, 10:39:27 AM

Author Topic: Mach3 to not recognize/move the x, y, and z axis while operating the spindle jus  (Read 8499 times)

0 Members and 1 Guest are viewing this topic.

This one will be a teaser!

I am using Dared's BOB on a Bridgeport Series II CNC Mill.

I remedied my previous problem and got down the road to a new problem.

The EStop on the mill and in software works just fine.  Also the spindle stops and starts like a champ.

But no axle movement at all.  None of the axis jog, or move while running a program.

MaxCL is enabled.

I think the problem lies in a setting in the software related to MaxCL.  For some unknown reason Mach3 simply isn't telling the axis to move, or possibly even recognizing any axis at all, given that all the axis are grayed out in Motor Tuning.

Jog is enabled with "continuous" set.  The Numlock is off.

I have checked the wiring and it is hooked up right with no breaks.

I am definitely NOT on a limit switch.  The mill bed is dead center and moves fine when the original BOSS control is hooked up.

When running a program, it just skims through all axis movements doing nothing, again leading me to believe Mach3 simply doesn't recognize any of the axis.

When the computer is running, here are the status of the LED's on Darek's board  The LED numbers correspond 1 to 1 with port pin numbers.
1,3,4,5,7,9,14,16,17 are on (lit)
2,6, and all the input's are off (unlit).
Input #10 is lit when the mill is first turned on, and goes off when the Limit Override button is pressed.

I'm stumped.  What would cause Mach3 to not recognize/move the x, y, and z axis while operating the spindle just fine?

What do you suggest?

Offline Tweakie.CNC

*
  • *
  •  7,956 7,956
  • Super Kitty
    • View Profile
    • Tweakie.CNC
I always ask silly questions, but why do you have MaxCL enabled ?.

Tweakie
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.

Offline Tweakie.CNC

*
  • *
  •  7,956 7,956
  • Super Kitty
    • View Profile
    • Tweakie.CNC
There is some info here that you may find solves your problem.

http://www.machsupport.com/forum/index.php/topic,8766.0.html

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
The reason I am using MaxCL is specifically because the installation instructions on Darek's BOB board tells me to.
Nowhere in his instructions does it mentions how to specifically set or enable the axis, just set MaxCL and don't worry about the rest.

Specifically, his instruction states:

"The software must be set to Max CL Mode (This is done under Config, Ports and Pins, Port Setup and Axis Selection.). When the software is in this mode you do not have to configure the motor outputs for the axis (Pins 2-9)."

And that's it.  Nothing else at all on setting up the drives.

Now I just received this email from Darek:

"Charles,

The axis have to be enabled X, Y & Z ( They use to come that way, the newest version of Mach 3 may have changed.) The PIN and PORT #'s assignment is automatic with MaxNC CL mode.

Thanks,
Darek"

But no explanation on HOW to enable the axis!

So I guess the question is, how do I enable the axis?

Thanks,
Charles.
Go to Config/Ports and Pins/Motor Outputs and set the green checks fro each axis.
Thanks!  That did it!