Hello Guest it is September 19, 2020, 03:18:58 PM

Author Topic: Mayday, mayday, mayday: Steppers thumping and banging and losing steps  (Read 3571 times)

0 Members and 1 Guest are viewing this topic.

Trouble at t'mill! I replaced the computer after the frost killed the old one off, and now it really won't play.  ???

It's a faster computer (1.5ghz Athlon over the 900mhz Pentium) and when jogging, with a 45khz kernel, it will easily drive at 2000 mm/min plus. However when executing G-code commands the buffer instantly exceeds 100% and the pulse train goes nuts, causing severe amounts of lost steps. I'm down to about 1200 mm/minute maximum now, and when executing a long, slow helical move it still loses steps, and the steppers thump and stumble.

Any common reasons why this would happen? I'm going to be in trouble if I can't get the beast dancing nicely, so any help offered would be sincerely appreciated. Thanks in advance :)

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Fresh install of the operating system is best, if it is, then possibly the optimisation steps will help. Another couple of things, if its a low voltage parallel port you may need a buffered breakout board (may already have that?) also you may be needing to change  the active state for Step/Dir pins.
Hood
Hi Hood, thanks for the suggestions.

Sorted it ... it was a fresh install, and the parallel boards i was using beforehand (MosChip items, very robust).

the problem turned out to be USB things again - I could make it crash by scooting the mouse about. It seems WXP prioritises USB demands over anything else, legacy ports in particular, and therefore any USB activity (even routine polling for changes) causes a machine crash.

Solution: disable all USB systems and use a PS2 mouse and kb. While I was there I stripped out the soundcard, network card and usb PCI card. This releases a lot of memory and lowers the amount of possible interruptions.  That done, it now interpolates helical paths at 1800 mm/min with only 24% buffer load. I think it could go a lot faster ;)

this USB thing has been a persistent problem ... any ways round it?  occasionally I need to get things on or off the mill.

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Afraid I have never had any USB issues on any of my machines but used wired stuff as I dont trust wireless stuff.
Hood
rapids now up to 2000 mm/minute with no lost steps. No wireless parts involved. Still stumped.

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Ah sorry saw you mentioning wireless in another post so just assumed.

Hood

Offline BR549

*
  •  6,932 6,932
    • View Profile
Blue, ran into some of the same things. Went to a PS2 keyboard and mouse. That fixed that part

To avoid other problems with the USB thumdrive for program tranfer, I never access the thumbdrive while in mach . If I need to load something I always leave mach then do what I need to do Close down the drive and then come back.

So far with those restrictions NO problems here.

I have a friend that uses a thumbdrive to run programs "from the usb thumbdrive" without a problem .

I can 't give you an answer as to why yet but I am still lookin.

Hope that helps

Offline simpson36

*
  •  1,371 1,371
    • View Profile
Look for shared interrupts between the USB and IDE, Graphics card, SCSI, etc.

I run g-code off a thumb drive no problem and have a USB mouse as well.
that may be an issue. I never got to working out how interrupt requests actually worked. Presumably sharing an IRQ number would cause problems, but is there a way to pioritise interrupt requests, one over another - ie set the paralell cards to one number, and the USB ports to another (lower?) figure?