Hello Guest it is October 21, 2019, 05:07:17 PM

Author Topic: Why doesn't OEMCode 307 jog?  (Read 1874 times)

0 Members and 1 Guest are viewing this topic.

Offline johnv

*
  •  43 43
    • View Profile
Why doesn't OEMCode 307 jog?
« on: May 17, 2010, 03:23:17 PM »
Hi All,
I want to add some switches to my control panel to jog X, Y, & Z axis similar to the lower buttons in the (tab) MPG Mode screen. Using OEMCode 307 for X+, when I push my X+ switch, the X stepper runs continuously and doesn't stop when I release the button. The Jog Mode in in Cont. Can anyone explain what I am doing wrong?.
Johnv

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Why doesn't OEMCode 307 jog?
« Reply #1 on: May 17, 2010, 03:28:58 PM »
What you want to do is assign the port and pin that you have the button connected to as Jog X++ which you will find down near the bottom of the list on Ports and Pins, Inputs.

Hood

Offline johnv

*
  •  43 43
    • View Profile
Re: Why doesn't OEMCode 307 jog?
« Reply #2 on: May 17, 2010, 04:39:36 PM »
Thanks again Hood! You've saved me 6 OEM Hotkeys. Thanks
Johnv

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Why doesn't OEMCode 307 jog?
« Reply #3 on: May 17, 2010, 04:58:07 PM »
LOL
If using the HotKey and OEM I think you need to press once to start jogging then press again to stop. Not very handy and I think that is why Art did it deeper in Mach and put the inputs direct rather than going through oems.
Hood