Hello Guest it is May 16, 2021, 04:31:42 AM

Author Topic: Mach pushes the motors faster than max speed... and it's not even ashamed of it!  (Read 2090 times)

0 Members and 1 Guest are viewing this topic.

Offline FXC

*
  •  45 45
    • View Profile
Everything was fine until today. I did nothing, I changed nothing. I noticed that my steppers sounded a little different when jogging and I discovered that they were running faster than the maximum speed set in the "Motor Tuning" window.

The max I have spec'd is 30 IPM, yet Mach now runs at ~35 IPM when jogging. I changed it to 20 max => ~24 when jogging. Same for feed rates: if the program says F10, Mach goes at approx. 12. And it shamelessly displays this high speed in the "Units/min" box.

I tried changing the motor speeds, the kernel speed, restarting the PC, etc. but nothing works. Mach keeps going some 20% faster than it should. Maybe it had too much coffee, WTH?  ???
Mach3 is a mess.

Offline FXC

*
  •  45 45
    • View Profile
A week has passed and it's still the same. An it looks like this will remain a mystery forever...

Oh well, thanks anyway!  :(
Mach3 is a mess.

Offline BR549

*
  •  6,952 6,952
    • View Profile
It could be that you have a multi speed CPU feature where the cpu can slow down and speed up. IF Mach locked in on a lower cpu speed, and then the CPU sped up you might get faster than normal velocities.

Here the CPU runs a touch SLOWER that what mach locked in on SO everything is a touch lower than indicated  10IPM= 9.46IPM

Try rerunning the driver test to see IF it can lock in on the faster speed.

Just a thought
« Last Edit: May 05, 2010, 11:50:18 PM by BR549 »