Hello Guest it is May 21, 2019, 05:11:17 PM

Author Topic: g95 problem when parting off  (Read 2186 times)

0 Members and 1 Guest are viewing this topic.

Offline mick

*
  •  60 60
    • View Profile
g95 problem when parting off
« on: April 29, 2010, 12:47:21 PM »
hello all,
          my question, is it possible to alter the feedrate dro to accept 3 decimal places.because when useing g95 with g20
          the minimum feed rate per rev is .010 and this is to heavy for my small lathe.
          i do use g21 sometimes in which case .05 is ok, but it does confuse my old head, and have just wrecked a part .
                                                                                                                                 
                                                                                              thanks mick.

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: g95 problem when parting off
« Reply #1 on: April 29, 2010, 02:02:05 PM »
If you command a G95 feed of 0.005 does it work correctly?
Changing the DRO is no problem if it does, I am at home now so afraid I cant test :(
Hood

Offline mick

*
  •  60 60
    • View Profile
Re: g95 problem when parting off
« Reply #2 on: April 29, 2010, 03:19:58 PM »
hi Hood,
        no it does'nt, the dro will only accept 2 decimals. if you use the mdi screen to enter  g95 f.005
        the dro reverts to .01.
                               thanks for coming back.  mick

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: g95 problem when parting off
« Reply #3 on: April 29, 2010, 03:27:44 PM »
Ok but even though the DRO reverts to 0.01 does the motion look like it is moving at the correct speed? If it does then its a simple thing to change the DRO to show three decimal places, all you do is open the screen in an editor such as Screen4 and double click the DRO in question. You will then see a line called Format String, if you change the 2 after the decimal to a 3 it will display 3 decimals in that DRO once you have saved and then started Mach again.
Hood

Offline mick

*
  •  60 60
    • View Profile
Re: g95 problem when parting off
« Reply #4 on: April 29, 2010, 03:48:53 PM »
Hood,
no the feed is as shown in the dro.
thanks for the info on Format string, i will alter that in screen4 ,maybe that will do the trick. mick.

wa hey Hood,
                   you've done it again complete success !!,the feedrate dro now accepts 3 decimals
                   and feed is as displayed.
 many thanks,  mick.
« Last Edit: April 29, 2010, 04:02:31 PM by mick »

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: g95 problem when parting off
« Reply #5 on: April 29, 2010, 04:22:30 PM »
:)

Hood