Hello Guest it is May 30, 2023, 10:31:06 AM

Author Topic: Help with SS and Servo drives please :(  (Read 3883 times)

0 Members and 1 Guest are viewing this topic.

Help with SS and Servo drives please :(
« on: April 22, 2010, 07:34:31 PM »
I have everything setup up and my friend has made me a g-code test file, but for some odd reason it keeps losing track of where it thinks the spindle is and loses its true soft limits. the smoothstepper is driving a cnc4pc's C10 BOB and thats connected to me servo drives.

When i ran the file that my friend did for me, i zeroed in my tool to my work piece then set the program off. initially the first line of code told the tool to do +10.000 then go down to a depth of -2.000. mach thinks its done this but in reality its only moved about -5mm from the original +10.000. if you leave it to run, it moves again to -4.000 as if it were doing a second pass but then goes all loopy and plows my tool through the table more or less.

On a second run of the same file it did not try to kill my table but to kill my X axis. as i have two motors moving X (A setup as a slave to X). For some bizarre reason tried moving A in the opposite direction of X.

One last thing is when i move the Z up and down then run abit of code, then stop and try to manually jog the Z in the + direction, there is no movement but mack thinks there is. the Z - works fine. I have to restart mach 3 and it works again.

My Servo drives do give of a large amount of interference when i enable them to "run", i have yet to successfully get my limit switches working because of this.

Altering de-bounce does not effect anything in anyway.

At the moment i have the SS board by my PC and the BOB is located in the cabinet with the Servo Drives and spindle inverter.   setup is like this ... PC --- usb cable --- SS ---- parallel cable --- C10 BOB --- screened cable --- Servo Drives
Heres a pic of my servo drive and bob.

hope someone can help

Re: Help with SS and Servo drives please :(
« Reply #1 on: June 13, 2010, 10:48:48 AM »
I don't have any specific experience with your specific hardware, but I can say that if the interference you refer to is so high that you can't use your limit switched then you must have big problems and probably shouldn't try to push the system further until you figure out a solution to the interference problem.

What kind of servo drives and motors are you using?  Do the servo drives have their own, internal motor power supply or do you have an external power supply that's providing motor power to the servos and motors?