Hello Guest it is May 21, 2019, 03:09:47 PM

Author Topic: pins 4 and 8 on ncPod to drive spindle step/dir?  (Read 1546 times)

0 Members and 1 Guest are viewing this topic.

pins 4 and 8 on ncPod to drive spindle step/dir?
« on: April 15, 2010, 06:53:21 PM »
Hi,

I have a 2d plotter running mach 3 with an ncPod. X and Y axes are pins 2,6 and 3,7 respectively in 'Ports and Pins', and 'pen up/pen down' is provided by the A axis. Originally I was using the Z axis (pins 4,8) to test drive the material deposition pump/pen thing (linear stepper), but decided to control this using the Spindle Speed Step/Dir option instead. So I disabled the Z axis, enabled 'Spindle', and gave it ports 4 and 8 (from the Z axis) so I wouldn't have to change any wiring.

Under the 'Spindle Speed' tab, all is default, except that 'Use Spindle Motor Control" and 'Step/Dir Motor' are checked, 'PWM Control' unchecked. Also. as I don't need delay for a pump, the 'Delay Spin' times are all set to zero; not that I'm sure I understand that this is what it's about anyway.

On entering 'G01 F10 X-5 Y-2 M03' in the midi screen, the X command executes, the Y doesn't (which is very odd), and the light above 'Spindle CW F5' lights yellow, but the pump doesn't respond. Following this with a reset, then 'G01 F10 Y-2 M03' gets the response 'Unknown word where unary operation could be'.

I'm guessing this is a pin number issue, but I don't know if I should be using the 'Output Signals' ports and pin dialogue boxes somehow. Confused, been a long day... This is the information from the ncPod manual:-

Output            Mach Pin #

PWM Gnd        NA      Just enable in Mach
C      Gnd        ***
E      Gnd        1
B      Gnd        3
D      Gnd        2
F      Gnd        4

It says under that:

-'You can select any output/enable you like in the “Ports and Pins”, “Output Signals” menu and set the “Port#” to 1
with the “Pin Number” matching the output you wish to use. For example; if I want to use “F” as output # 3, from the
main menu in Mach I would select “Config”, “Ports and Pins”, “Outputs” tab and check “Output #3. For the “Port#”
setting I would enter “1” and for the “Pin Number” enter “4”.'

I probably have all the information here to sort this out, but can't make head or tail of it at the moment.

Anyone willing to point this out to me?

Thanks,

Richard B