Hello Guest it is January 26, 2020, 10:19:57 PM

Author Topic: Steppers not steppin'  (Read 2163 times)

0 Members and 1 Guest are viewing this topic.

Steppers not steppin'
« on: April 08, 2010, 06:06:41 PM »
I was calibrating my CNC (Xylotech motors) and pretty well got that perfect, using a dial gauge for measurement.  All my jogging by keyboard or G0 commands worked without issue.  Then I decided I wanted to change units from inches (what I used for calibration) to mm, DESPITE the warning not to do so, because I was having problems with a program using metric units.  I finally found out that G20 and G21 are the commands I should be using, but when I went back to running the program or checking the jogging, my motors did not work.  I tried to undo anything I thought was the problem, to no avail.  Then I complicated matters by downloading the latest version of Mach3.  I had Version 3.00 originally.  This didn't help.

NOW, when I jog, the DRO increment or decrement as they should but the motors do not move whatsoever.  When I try to zero any axis, once again the DRO's inc or dec VERY slowly but nothing physical moves.

Any ideas?  I tried rebooting, running the old mach3 and went over pretty well all the settings to see where I screwed up.
Re: Steppers not steppin'
« Reply #1 on: April 08, 2010, 08:27:36 PM »
check the config/port and pons/motor outputs
to see if your dir and step pins are enabled and correctly configured?

check if by mistake you press the online/offline button?

Regards
Re: Steppers not steppin'
« Reply #2 on: April 09, 2010, 05:36:13 PM »
Thanks for the reply.  I had checked all those items but had an epiphany and went back to basics.  There it was: the port number had SOMEHOW, and strangely been set to non-hex characters from the expected 0x378.  I have no idea how it happened, since there was no reason for me to change it.  Anyway, I set it to 378 and all worked again.   My laptop did go wonky later on and I had to reboot it.