Hello Guest it is May 19, 2019, 03:01:17 PM

Author Topic: Can anyone help me with this GCode?  (Read 1936 times)

0 Members and 1 Guest are viewing this topic.

Can anyone help me with this GCode?
« on: April 07, 2010, 12:12:58 PM »
I created this code in Cut2d and i'm running Mach3 on my router. However when i cut this piece it does not follow the toolpath shown on the screen in either mach3 or cut2d.  Its starts out ok but at the same spot everytime it goes off on its own thing.

Offline Tweakie.CNC

*
  • *
  •  7,762 7,762
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Can anyone help me with this GCode?
« Reply #1 on: April 07, 2010, 12:38:00 PM »
Just ran your code and it appears OK (not the most optimized code I have seen however).

At what point does it all go 'pear shaped' and what happens to the tool path ?.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Can anyone help me with this GCode?
« Reply #2 on: April 07, 2010, 12:47:14 PM »
The operation with all the holes is done ok- they are not perfect circles but that is the least of my problems with this.....The left square- the bottom line goes ok...however it starts the vertical side lines and does them slanted??? From there it only goes further off path to do crazy lines that don't seem to represent anything in the designated toolpath.  Could this be more a problem with the way Mach3 is configured with my router than a GCode problem itself?

Offline Tweakie.CNC

*
  • *
  •  7,762 7,762
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Can anyone help me with this GCode?
« Reply #3 on: April 07, 2010, 01:09:26 PM »
It's not the GCode that is at fault here or it would produce the same results for me.

You are correct in that you need to look at your configuration settings and double check everything.

Tweakie.

Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.