Hello Guest it is June 19, 2019, 11:50:19 AM

Author Topic: Index pulses in diags but machturn doesn't see it anywhere else  (Read 3383 times)

0 Members and 1 Guest are viewing this topic.

Index pulses in diags but machturn doesn't see it anywhere else. I am using the latest locked version and an old reliable machine.

Offline Hood

*
  •  25,844 25,844
  • Carnoustie, Scotland
    • View Profile
Re: Index pulses in diags but machturn doesn't see it anywhere else
« Reply #1 on: April 06, 2010, 03:22:57 PM »
What are you meaning by Diags? is that the screen or the plugin?
Where are you expecting to see the index pulse?
Hood
Re: Index pulses in diags but machturn doesn't see it anywhere else
« Reply #2 on: April 06, 2010, 03:29:30 PM »
Sorry, I meant the diagnostic screen in Mach3Turn. The index flashes at the appropriate times on the screen to show me that the software is getting the signal but when I go to calibrate the spindle speed, it tells me to start the spindle first, which of course I all ready have. I also see no rpm readout anywhere in Mach3Turn.

Offline Hood

*
  •  25,844 25,844
  • Carnoustie, Scotland
    • View Profile
Re: Index pulses in diags but machturn doesn't see it anywhere else
« Reply #3 on: April 06, 2010, 03:35:48 PM »
Have you started the spindle by commanding a M3?
Hood
Re: Index pulses in diags but machturn doesn't see it anywhere else
« Reply #4 on: April 06, 2010, 04:26:57 PM »
Well, I haven't gotten to the program yet. I'm still trying to calibrate the spindle. The second line of the code does have an M3.

Offline Hood

*
  •  25,844 25,844
  • Carnoustie, Scotland
    • View Profile
Re: Index pulses in diags but machturn doesn't see it anywhere else
« Reply #5 on: April 06, 2010, 04:58:59 PM »
In the latest versions of Mach, when using the parallel port driver,  I believe you need to have a relay set for the spindle, even if its an imaginary one, and also for the RPM to show you need to command a M3. Pressing the button on the screen should do the M3 so if that is what you are doing it should be ok.
Hood
Re: Index pulses in diags but machturn doesn't see it anywhere else
« Reply #6 on: April 06, 2010, 07:25:17 PM »
When I press the spindle on button in spindle calibration screen I get a momentary dwell light then nothing except the message to turn my spindle on. When I try to calibrate spindle in Mach3Mill it works fine.
« Last Edit: April 06, 2010, 07:28:41 PM by kdoney »
Re: Index pulses in diags but machturn doesn't see it anywhere else
« Reply #7 on: April 06, 2010, 07:54:41 PM »
That got it. I didn't understand about the relays until now. Thanks