Hello Guest it is January 26, 2020, 09:33:14 PM

Author Topic: SLOW JOG RATE OEMDRO ?  (Read 5140 times)

0 Members and 1 Guest are viewing this topic.

SLOW JOG RATE OEMDRO ?
« on: April 02, 2010, 05:07:21 AM »
Hello,

i am wondering if the slow jog rate has an oemdro which can be set in VB?

For Feedrate for example i use OEMDRO 18 , but i can't find anything about slow jog rate...

Can anybody please help?

Thank you

Joachim

Offline ger21

*
  • *
  •  6,291 6,291
    • View Profile
    • The CNC Woodworker
Re: SLOW JOG RATE OEMDRO ?
« Reply #1 on: April 02, 2010, 09:33:00 AM »
OEM DRO 3 is slow jog %
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: SLOW JOG RATE OEMDRO ?
« Reply #2 on: April 02, 2010, 11:51:44 AM »
Thank's a lot, that did it !

Joachim  :D

Offline Doorn

*
  •  12 12
    • View Profile
Re: SLOW JOG RATE OEMDRO ?
« Reply #3 on: July 31, 2010, 08:43:40 AM »
Hello,

I have small problem that goes in the same direction as the above.

I use a touch sensor to compensate the tool length in macro.
The tool moves to the highest position above the sensor, moves down and touches the sensor.
Next it moves up and down again in small incremental steps to determine the exact length.
When I've changed the tool manually it repeats this and the length difference is corrected in the offset cords.

The first move down i did with incremental steps of 1mm checking the sensor between each step to prevent the tool from crashing into the sensor but this takes to long. Now i want to use a jog command which is terminated as soon as the sensor is touched.
I can however not slowdown the jog speed in the macro and it crashes into the sensor before it can stop.
Jog is related to the maximum speed. My FRO alters the normal speed and the jog percentage in the macropump.
Therefore i can not alter the jog percentage (OemDRO 3) in the toolchange because it's directly changed by the macropump again.
I tried changing OEMDRO 104 (the maximum feedrate), but this didn't change the jogspeed.

Is there a way to lower the jogspeed when i can not alter the  jog percentage?

thanks in advance
David

Offline BR549

*
  •  6,925 6,925
    • View Profile
Re: SLOW JOG RATE OEMDRO ?
« Reply #4 on: July 31, 2010, 09:42:45 AM »
Sounds like catch22 to me(;-).  I personely would never run a routine from the Macropump THAT would not allow "me " to controll the machine properly such as your FRO routine BUT that is for you to decide.

You can always program in a bypass to the macropump that would override the FRO overide IF a condition was met. For example when you wanted to run the tool touchoff set a led ON and this would bypass the FRO overide routine in your macropump.

(;-)

Offline Doorn

*
  •  12 12
    • View Profile
Re: SLOW JOG RATE OEMDRO ?
« Reply #5 on: August 01, 2010, 07:27:50 AM »
The FRO routine works, only not on fly now I'm using a pokey, i used a G100 before there the feedrate change was instantly, but i fried it. :(
The speed during programs can be changed normally with the F command, only a FRO setting change has a delay of about 2 sec.
For jogging i need to release the jog button first and then the new FRO percentage becomes active. On fly would be better, but during the toolchange i don't want to depend on me constantly holding the pendant anyway.
Your idea about bypassing the FRO loop or just the update line during the toolchange will probably solve my problem indeed.

Many thanks i.m going to try it.

Offline Doorn

*
  •  12 12
    • View Profile
Re: SLOW JOG RATE OEMDRO ?
« Reply #6 on: August 03, 2010, 07:41:59 AM »
Unfortunately it does not work relyable, although I do not know if this has anything to do with bypass. :(
I tested it several times and it worked twice, but failed about 10 times (random).
The Jog rate indeed slows down, but for some reason the second time it has to touch the sensor the toolchange macro freezes and does not descend.
The problem is that the first touch move and the second touch move is copy paste and are completely identical.
I don't know if it has anything to do with two macros trying to access the same led, but at the point where the macro freezes it's not writing to the led.
I have to look further into this, but i'm running out of ideas  :-\

Offline Doorn

*
  •  12 12
    • View Profile
Re: SLOW JOG RATE OEMDRO ?
« Reply #7 on: August 03, 2010, 08:30:59 AM »
Found it,  ;D
I use DoOemButton(336) to abort the jog movement, this is a toggle.
I use it for normal jog too, but that's in the macropump which starts from new every time so i do not have to toggle on again.
In the toolchange i do two jog moves after eachother and toggling off in between i forgot to toggle on again, therefor the macro never finished.