Hello Guest it is July 19, 2024, 10:09:29 AM

Author Topic: Losing steps in one direction each axis  (Read 3905 times)

0 Members and 1 Guest are viewing this topic.

Offline w3

  •  2 2
Losing steps in one direction each axis
« on: March 26, 2010, 08:15:16 PM »
Hi, I built a Joes 4x4 about five months ago using kellinginc 425 motors and drivers along with the c10 bob that all came as a kit. I spent a week or more trying everything anyone would suggest and anything I could see to change to solve the issue I was having then finally plugged the machine into a laptop and it worked so I left it at that figuring the parallel port was bad in the desktop.

My problem sounds just like this thread I found in machsupport unfortunately it looks like the thread ended without resolution. As the machine runs error accumulates in one direction on each axis, always the same direction and more depending on the amount of moves made so a 3d cut adds up fast on the Z.

Well a couple of weeks ago the laptop died, I had purchased a lava pci lpt card so I went to install it in the desktop and found the motherboard dead... so I purchased and installed a new motherboard (skyhawk in a hp d325 athlon 2800+ with 1 GB ram) trying the lpt port on the new motherboard gave the same problem so I installed the pci lpt card and still the same issue.

So now I know it worked fine on the laptop, it had problems with the lpt on two desktop motherboards and with the lava adding card which makes me think it is not an issue with the computer at all. Could this be electrical noise somewhere that did not show with the laptop because of lower voltages or something? I am lost with electronics so I wouldnt know where to start but it just baffles me that the problem only appears when driving the machine with a desktop computer. I have another desktop coming that I will be trying next week though my confidence is hitting a new low as far it working.


Offline w3

  •  2 2
Re: Losing steps in one direction each axis
« Reply #1 on: March 26, 2010, 08:31:56 PM »
Well I found a post by the OP in the above linked thread with his solution.

I started a thread called "is this a bug in Mach 3" as i was having a similar sort of problem. It's been deleted.

I was consistently gaining steps which it seems that you have the same problem.

I have now resolved the issue and it was down to one of three things.

1: I was using a BOB that had opto isolated outputs and my drivers had opto isolated inputs. IE two sets of opto isolators.

2: There was noise in the BOB board.

3: I hadn't wired the drivers correctly.

The problem is resolved due to a change of BOB that no longer has opto isolated outputs to the drivers

I also changed the wiring to the drivers the original wiring had a common ground the steps and direction were connected to the positive side of the drivers they are now wired as 5V common the negative now controls the steps/dir signals

Basically what was happening was on every direction change some extra steps were added.

It happened on every axis by the same amount.



I will try and decipher this and see if I can work this out. What has me really turned around though is that the issue did not present itself when running on the laptop, The computer it well away from the bob and drivers (4') but plugged into the same circuit.