Hello Guest it is May 19, 2019, 11:08:38 PM

Author Topic: Pulse problem  (Read 2940 times)

0 Members and 1 Guest are viewing this topic.

Pulse problem
« on: March 17, 2010, 03:28:46 PM »
Just set up Mach3 on a new,(recon), computer and have a problem with the pulse outputs. Driver test exellent. Checked pulses with scope and instead of 5 us pulses with variable frequency I have variable pulse width, ie PWM. This is on X and Y outputs. Also I have the same waveform on the direction pins as well. Is there a setting for this I have overlooked, I know about the spindle PWM setup but I am not using that.
Any ideas?

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: Pulse problem
« Reply #1 on: March 17, 2010, 03:50:28 PM »
Sounds like you may have used the Max CL or Max NC option by mistake.
Hood
Re: Pulse problem
« Reply #2 on: March 17, 2010, 04:40:37 PM »
Please excuse my lack of knowledge here but where do I select, or deselect, max CL and NC. Also I have checked the waveforms again and I might be wrong about the PWM. It seems I have a 50/50 square wave and the frequency just increases with speed???
Re: Pulse problem
« Reply #3 on: March 17, 2010, 04:46:14 PM »
Under Config / Ports and Pins.....on the right side.

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: Pulse problem
« Reply #4 on: March 17, 2010, 04:47:53 PM »
Yes frequency should increase with speed but it should only be on the Step pin, Dir should go High or Low depending on direction you are moving.
To see if you have the Max modes checked look at Config menu then Ports and Pins, its at the right on the main page there, if you do just take the check out the box.
Hood
Re: Pulse problem
« Reply #5 on: March 17, 2010, 05:10:59 PM »
Thanks Hood and Overloaded, I have unchecked max CL and system is now working.

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: Pulse problem
« Reply #6 on: March 17, 2010, 05:12:38 PM »
:)

Hood