Hello Guest it is October 16, 2019, 06:22:29 AM

Author Topic: G31 Probing problem  (Read 2204 times)

0 Members and 1 Guest are viewing this topic.

G31 Probing problem
« on: March 15, 2010, 03:48:33 AM »
Hello, I'm hoping to get some help.  I'm having a hard time with a g31 probing routine.  This is a macro and gcode that originally was posted by Terry (Vmax549).  It's a internal polar aray routine that probes the inside of a part in the x and y direction.  I modified it to be able to specify a Z depth amount and Z depth step amount so it would probe down say an inch or two in what ever step size i specify.  It cycles just fine for a while, but at some random point as it completes a step or more in z direction the G31 command doesn't send the probe out more than a tenth or so, it just jerks in short steps for a cycle or two or sometimes more and then it starts working again.  I've tried changing to slower feed rates, and everything else I can think of, but I"m out of ideas as to what could be causing this.  Sometimes it's around 40 G31 calls before it fails and other times it has been several hundred.

I updated to the latest lock down version of Mach3 today to try to solve this, but it didn't change anything.

I've included the files for anyone who would like to take a look at this.

Re: G31 Probing problem
« Reply #1 on: March 30, 2010, 03:29:48 AM »
Here's an update on this.  The G31 probing code still does not work consistently.  I've reworked the Gcode, and I even wrote it in a VB Macro.  In each case the end result is the same.  It will go along for a while running the G31 probing routine, but then it totally fails.  I've checked the variables for x and y and they are present, yet it won't probe.  After doing the "HERKY JERKY" for 8 to 16 cycles, it starts working again.  I'm beginning to think this is a Mach3 problem.  Anyone have an idea that I might try?

Bob
Re: G31 Probing problem
« Reply #2 on: March 30, 2010, 03:32:18 AM »
Here's the newest Gcode file.