Hello Guest it is October 15, 2019, 05:56:00 PM

Author Topic: RPM and counting ?  (Read 12578 times)

0 Members and 1 Guest are viewing this topic.

Offline RICH

*
  • *
  •  7,367 7,367
    • View Profile
Re: RPM and counting ?
« Reply #20 on: April 02, 2010, 10:55:33 PM »
CONFIGURATIONS:
config>PORTS AND PINS>INPUT SIGNALS - enable the index, assign the port amd pin #, set active low
                                                            - timing should not be enabled
                                   >SPINDLE SET UP - relay control unchecked, use spindle feedback should be checked and also spindle
                                                                speed feedback
You need to turn on the spindle in order for rpm to be displayed...so in MDI type M3


RICH
                                         
Re: RPM and counting ?
« Reply #21 on: April 02, 2010, 11:13:17 PM »
ok Rich, check the settings and all looks good.  Here are some pics and the XML file.

Offline RICH

*
  • *
  •  7,367 7,367
    • View Profile
Re: RPM and counting ?
« Reply #22 on: April 02, 2010, 11:16:43 PM »
No attachments were included in your reply.
RICH
Re: RPM and counting ?
« Reply #23 on: April 02, 2010, 11:21:10 PM »
For some reason attachments are not working for me, Ill keep trying.

Finally, man, I am having one hell of a night.

Offline RICH

*
  • *
  •  7,367 7,367
    • View Profile
Re: RPM and counting ?
« Reply #24 on: April 02, 2010, 11:45:37 PM »
quick look at xml and looks ok.
now let me look harder at the wiring in your pics.

RICH

Offline RICH

*
  • *
  •  7,367 7,367
    • View Profile
Re: RPM and counting ?
« Reply #25 on: April 02, 2010, 11:51:24 PM »
Where are you running the ground wire conn #3 / blue wire which is ground on the sensor?
rich

Offline RICH

*
  • *
  •  7,367 7,367
    • View Profile
Re: RPM and counting ?
« Reply #26 on: April 02, 2010, 11:53:53 PM »
When you check the voltage from the sensor output does it change from the high of 20 volts to a low of 0 volts  when you turn the spindle ?
RICH
Re: RPM and counting ?
« Reply #27 on: April 02, 2010, 11:54:48 PM »
In Pic 2 your can see it, grounded to the 24 volt output terminal block.
Re: RPM and counting ?
« Reply #28 on: April 02, 2010, 11:56:32 PM »
When I check the normally closed wire voltage and the sensor LED is OFF, voltage output is 0V ion the normally closed wire.  When I rotate the spindle and the sensor LED is on I get 5V output on the normally closed wire.  Without the 5V regulator I would get about 22V.

Offline RICH

*
  • *
  •  7,367 7,367
    • View Profile
Re: RPM and counting ?
« Reply #29 on: April 03, 2010, 12:05:33 AM »
Good so the sensor is working.
Do you see the LED in diagnostics turning on and off?
RICH