Hello Guest it is December 12, 2019, 02:22:08 PM

Author Topic: Mach 3 Turn Random Movements  (Read 3029 times)

0 Members and 1 Guest are viewing this topic.

Mach 3 Turn Random Movements
« on: February 22, 2010, 06:14:46 AM »
There is an issue which I suspect is a glitch in Mach 3 Turn. The X axis moves every few seconds by itself in a positive direction when the index pulse is connected. It seems to happen at the same rate no matter what the spindle speed is ( about 0.5mm every few seconds at random intervals ). If the spindle motor is running and I disconnect the index pulse the random movements stop. I originally thought it was noise from the motor or VFD but apparently not.

These are commanded moves from Mach 3 - ie the DRO on the screen moves. It seems to hold position during a cut from G Code but starts moving again during feed hold or with no G Code loaded.  I have disabled the MPGs in "Ports & Pins", and disabled the joystick plugin. These are recent additions to the machine. I have been using this machine for a couple of years every so often for hobby use and haven't noticed this fault before.

I'm using version R2.3 according to the "About Mach 3" under "Help". I haven't updated because I mainly do threading on this lathe and it does that well.

Glen.
I had a few parts left over - still it's always the same when you try a bit of "do it yourself"

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Mach 3 Turn Random Movements
« Reply #1 on: February 22, 2010, 06:17:35 AM »
Please attach your xml.
Hood
Re: Mach 3 Turn Random Movements
« Reply #2 on: February 22, 2010, 07:47:17 AM »
XML Attached, had to rename it as the forum said this file name had been posted before.
Thanks Hood.
I had a few parts left over - still it's always the same when you try a bit of "do it yourself"

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Mach 3 Turn Random Movements
« Reply #3 on: February 22, 2010, 09:19:42 AM »
You have the same pin as you have for the index working an OEM trigger, that is likely your problem.
Hood

Just found the definite culprit, you have the same pin as you are using for the index set up for the X++ JOG, so everytime the index is seen it will look like a press of a jog X++ button.
When code is running Mach disables all external jog commands so thats why you only see when stopped or in feedhold.

Hood
« Last Edit: February 22, 2010, 09:32:33 AM by Hood »
Re: Mach 3 Turn Random Movements
« Reply #4 on: February 23, 2010, 01:32:17 AM »
Thanks so much Hood. The external jog buttons were something I was playing with about a year ago and had forgotten about. I recently moved the index pulse to another pin as I was getting noise in the signal. The source of the noise was discovered but later I noticed the X axis moving. I've disabled the external jog inputs and everything is fine now.
Once again thanks for your help and fast result.
Glen.
I had a few parts left over - still it's always the same when you try a bit of "do it yourself"

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Mach 3 Turn Random Movements
« Reply #5 on: February 23, 2010, 03:07:55 AM »
No probs Glen.

Hood