Hello Guest it is November 15, 2019, 07:41:56 AM

Author Topic: Setting Home and limits  (Read 7205 times)

0 Members and 1 Guest are viewing this topic.

Setting Home and limits
« on: September 25, 2006, 07:10:01 PM »
Hello,
I have been using my router with only limits setup.  I'm trying to setup so that Mach3 will use one of the limit switches on each axis as a home switch.  I have two limit switches on each axis. For X-axis, I setup in series the + and - limits as one. the same goes for the Y and Z axis.  I have a rotary axis without any limits.  When I home the X-axis the head moves towards the limit/home and it hits the limit. Then it keeps trying to move farther hitting the physical end of the machine.  I have tried to change the debounce from 0 to 500, 1500, 2000 but it does not change anything.  In the Diagnostic page when I touch one of the limits it lights the LIMITOV LED.  What am I going wrong?  Any help would be appreciated.


The signal inputs I setup as follows:
X++       Pin#11
X--         Pin#11
X home  Pin#11
Y++       Pin#12
Y--         Pin#12
Y home  Pin#12
Z++       Pin#13
Z--         Pin#13
Z home  Pin#13

Re: Setting Home and limits
« Reply #1 on: September 26, 2006, 03:00:27 AM »
enytned1,

I'm not sure how this is suppose to work but have you checked the enable fields
in the ports & pins input signals for your switches. You may also want to try to
change the active low to active high or visa-versa. Also in the config state, I would
think the Home Sw Safety box should be checked.
Maybe this will help.

Al
Re: Setting Home and limits
« Reply #2 on: September 26, 2006, 06:52:54 AM »
That should work... could you post your XML so we can have a look at your settings?
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com
Re: Setting Home and limits
« Reply #3 on: September 26, 2006, 08:19:54 AM »
I will post the XML file when I get home from work.  The limits switches work fine, when the heads move to far and hit the limit it always stops on all the limit switches. 
Re: Setting Home and limits
« Reply #4 on: September 26, 2006, 08:34:47 AM »
I don't remember if I checked the config/state Home Sw Safety box.  I was not even aware that this box had to be checked.  From reading about this check box I think it is very important when setting the limits and home as the same.  Thank you for the suggestion.
Re: Setting Home and limits
« Reply #5 on: September 26, 2006, 06:18:06 PM »
Here is my XML file, Mill options settings and Initial State Settings.
Re: Setting Home and limits
« Reply #6 on: September 26, 2006, 06:19:03 PM »
Here is the Initial State settings and Mill options.

Offline Chip

*
  • *
  •  2,056 2,056
  • Gainesville Florida USA
    • View Profile
Re: Setting Home and limits
« Reply #7 on: September 26, 2006, 08:34:43 PM »
Hi, Enytned1

Downloaded your XML, In your Mach3 folder you'll find a file called LastErrors.txt it has your error for last run it shows as follows.

Tue - 19:05:02 ---Program Startup
Tue - 19:05:12 ---Softlimits Max < Min--------------This is probily causing your problem.

After I changed settings, Changed, Z max to 6.00, Z min 0.00, Checked the Home neg for X, Y in Config HomeLinits.

Tue - 19:17:59 ---Program Startup
Tue - 19:18:05 ---

If your axis X, Y, Z,  move backward's, check the Reversed  in HomeLimitsr for them.

Not nowing how you have your machine set up.

Most Machine's are set - up with  Home, Spindle Up Z+, the left front edge of table X-, Y-, under spindle, X being left to right and Y forward  and aft.

Hear is a XML file to try.

Hope this Help's Chip

Re: Setting Home and limits
« Reply #8 on: September 26, 2006, 10:06:39 PM »
The machine I have is an old Techno isel Model27 gantry system 3 router.  Manufactured in 1997 from what I was told when I bought it and it was not working when I picked it up.  It has 6 limit switches 2 on each axis connected in series.  The machine did not come with techno control software or the cards.  I am actually glad it does not have the original software because it gave me a chance to install this great software from Mach and actually have a greater understanding of the industry.  I not sure but Techno must use one of the limits as a home on each axis.  What should be the step by step procedure in setting up one limit on each axis as a home for this king of router?

Link below is what I have only 10 older:
http://www.techno-isel.com/CNC_Routers/CNCRouter_B2.htm

Offline Chip

*
  • *
  •  2,056 2,056
  • Gainesville Florida USA
    • View Profile
Re: Setting Home and limits
« Reply #9 on: September 26, 2006, 10:25:40 PM »
Hi, Enytned1

You probably still need to fix the error,
Tue - 19:05:02 ---Program Startup
Tue - 19:05:12 ---Softlimits Max < Min--------------This is probity causing your problem.

In Config, Ports Pins, Input Signals, set X Home, Enable, Port 1 Pin # 10 or 15 ...... you don't have enough pins for all Axis's with out adding another Parrell port.

It will work if you set it up properly the way it is now.

Thank's Chip