Hello Guest it is July 17, 2019, 09:35:26 AM

Author Topic: simulate probe  (Read 4985 times)

0 Members and 1 Guest are viewing this topic.

simulate probe
« on: January 30, 2010, 12:33:43 PM »
Is there anyway to simulate a probe contact?  I am using Mach on another computer (not hooked up to my mill) and I am testing probe macros and would like to simulate a probe contact to see if the macro works.
Re: simulate probe
« Reply #1 on: January 30, 2010, 12:37:01 PM »
Just connect a momentary switch to the appropriate pin.

You need to do this before you run the macro in real time to make sure nothing unexpected happens before using it on the machine

Phil
The Good Thing About Mach3, Is It's very Configurable

The Bad Thing About Mach3, Is It's Too Configurable
Re: simulate probe
« Reply #2 on: January 30, 2010, 12:47:55 PM »
................or you can got to INPUT SIGNALS and set a hot key for it.
I use it all the time.
Russ
Re: simulate probe
« Reply #3 on: January 30, 2010, 12:55:15 PM »
You can check that the emulation is working by looking at the DIGITIZE LED on the Diag. screen while hitting the hotkey.
Re: simulate probe
« Reply #4 on: January 30, 2010, 12:57:19 PM »
Always something to learn here.

But you still better do it for real before you break your probe/cutter.

Phil
The Good Thing About Mach3, Is It's very Configurable

The Bad Thing About Mach3, Is It's Too Configurable
Re: simulate probe
« Reply #5 on: January 30, 2010, 08:12:43 PM »
thanks folks alot of good information here

Offline stirling

*
  • *
  •  2,188 2,188
  • UK
    • View Profile
    • www.razordance.co.uk
Re: simulate probe
« Reply #6 on: January 31, 2010, 05:47:30 AM »
If your simulation Mach hasn't got the PP driver loaded then:
Although the emulated mode (using hot keys) will light the digitize LED, if you do a G31 it won't work as you might expect when you hit a key (i.e. stop and record position into the gcode params)
Solution is to load the PP driver even though you have no actual machine attached.

Cheers

Ian
Re: simulate probe
« Reply #7 on: January 31, 2010, 04:05:27 PM »
when I give the g31 comand the probe won't stop it.  The probe light is lighting but it just keeps going.  Any help with this?
Re: simulate probe
« Reply #8 on: February 01, 2010, 09:39:11 AM »
also I used a hot key "p" and when I press it nothing happens no digitize light or any other reaction.
Re: simulate probe
« Reply #9 on: February 01, 2010, 11:49:08 AM »
Are you sure it is ENABLED and the EMULATED box is checked ?
I used "H", not sure if "P" is used elsewhere or not.
Works like a charm here.
RC