Hello Guest it is July 18, 2019, 06:12:09 PM

Author Topic: Mach3 bug ?  (Read 4076 times)

0 Members and 1 Guest are viewing this topic.

Mach3 bug ?
« on: January 29, 2010, 03:40:48 AM »
This relates to a mill using ver 036 and PP

I made some gcode with some G43's the program on first loading runs through and doesn't throw any errors.

The first toolchange goes OK "Manual" when i come to the next toolchange the program halts after i hit cycle start with SOFTLIMITS MOVEMENT ABORTED

This is nothing to do with the tool length as i changed the tool length to 2mm

If i comment out the G43 it will run OK

If i take out the T06 it will run OK with the G43 line in

The G43 line is G43 H2 D0

Has anyone else gotten over this problem ?

Phil
The Good Thing About Mach3, Is It's very Configurable

The Bad Thing About Mach3, Is It's Too Configurable
Re: Mach3 bug ? Tool Change problem
« Reply #1 on: January 30, 2010, 12:27:55 PM »
Ok thanks for the help. ???

My code is generated by CAM

What was happening was i left the tool length offset enabled so got the error on soft limits.

Added a G49 at the end of the tool change so the next tool change didn't activate the soft limits

Hope this helps someone.

Phil
The Good Thing About Mach3, Is It's very Configurable

The Bad Thing About Mach3, Is It's Too Configurable

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 bug ?
« Reply #2 on: January 30, 2010, 12:53:44 PM »
Thanks for the answer Phil, as you say it will hopefully help someone else out :)
Hood
Re: Mach3 bug ?
« Reply #3 on: January 30, 2010, 12:54:48 PM »
Yeah but only if they do a search. ;D ;D ;D

Phil
The Good Thing About Mach3, Is It's very Configurable

The Bad Thing About Mach3, Is It's Too Configurable

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 bug ?
« Reply #4 on: January 30, 2010, 12:57:12 PM »
Yes true, then again  I may remember your issue and may remember the resolution so will be able to tell them ;D

Hood

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Mach3 bug ?
« Reply #5 on: January 30, 2010, 01:00:22 PM »
Unfortunately, the it's very hard to find anything with the search here, unless you know exactly what you're looking for. At least from my experience. Having an option to Google search the forum would be much better.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Mach3 bug ?
« Reply #6 on: January 30, 2010, 01:00:55 PM »
Yes that's true, what would we do all do without you :)

Phil
The Good Thing About Mach3, Is It's very Configurable

The Bad Thing About Mach3, Is It's Too Configurable

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 bug ?
« Reply #7 on: January 30, 2010, 01:03:02 PM »
Yes that's true, what would we do all do without you :)

Phil

Probably jump for joy ;D
Re: Mach3 bug ?
« Reply #8 on: January 30, 2010, 01:11:10 PM »
Unfortunately, the it's very hard to find anything with the search here, unless you know exactly what you're looking for. At least from my experience. Having an option to Google search the forum would be much better.

Yeah just tried, i had to use advanced search, soft limit nothing, softlimit nothing, softlimits found this thread.

So be nice to Hood  ;D

Phil
The Good Thing About Mach3, Is It's very Configurable

The Bad Thing About Mach3, Is It's Too Configurable