Hello Guest it is December 14, 2019, 01:21:38 PM

Author Topic: Good servo tune in Axis Works is way different in Mach 3 ??  (Read 5453 times)

0 Members and 1 Guest are viewing this topic.

I can get my servo motors tuned pretty good in Axis Works but when I start Mach 3 they act totally different and out of tune. I have checked and double checked everything. I Make sure the velocity and acceleration is all the same as I used in axis works. I have uploaded the xml file multiple times. My PIDS have to be sky high to operate in Mach 3 verses what was good in Axis Works. I can manually inspect the XML and the settings are what I saved in Axis Works and there isn't a problem. I go back to Axis Works and all runs smooth as is. I just dont know what I'm doing wrong.

For example I set my X axis PID in Axis Works at P 250 and D 1800. Scale is 1 and I is 0. Runs good in Axis Works and zeros every time. I save and close the program. I check the xml to make sure its saved and start Mach3. Jogging nearly shakes the machine at a variety of velocities. Its not just that particular setting. Whatever setting just does not act the same under Mach 3. What am I not doing right?

RonO
Re: Good servo tune in Axis Works is way different in Mach 3 ??
« Reply #1 on: January 19, 2010, 12:18:17 AM »
Hi Ron,
If you want, send me your DSPMC xml file and the Mach3 xml file which would either be the Mach3mill  as the default or if you made a custom profile, that one.

I will take a look and see if it is anything obvious.

Mike
We never have the time or money to do it right the first time, but we somehow manage to do it twice and then spend the money to get it right.
Re: Good servo tune in Axis Works is way different in Mach 3 ??
« Reply #2 on: January 19, 2010, 09:09:54 AM »
Hi Ron,
If you want, send me your DSPMC xml file and the Mach3 xml file which would either be the Mach3mill  as the default or if you made a custom profile, that one.

I will take a look and see if it is anything obvious.

Mike


Theres a question. I thought it only accessed the dspmc.xml file. Thats the only one I have ever saved to.
Re: Good servo tune in Axis Works is way different in Mach 3 ??
« Reply #3 on: January 19, 2010, 12:18:47 PM »
No , it only uses the dspmc "C:\Mach3\Mach3.exe /p dspMC". I dont have any other xml's anymore.
Re: Good servo tune in Axis Works is way different in Mach 3 ??
« Reply #4 on: January 21, 2010, 10:05:38 AM »
If you go to the mach3 folder which is C:\mach3. You need to have 2 xml files. One is dspmc.xml. This is the file that the DSPMC looks at for motor tuning.
Your other xml file should be Mach3mill. Mach3mill is one of the default xmls that Mach3 creates when you install Mach3. If you create one and it is recomended that you do you can call it Mymill or Mylaser or what ever. This is the file that Mach3 looks at for your pins and ports and all of the non DSPMC related info.

The dspmc.xml file is on the vitalsystem website if you can't find it.

When you open Mach3 loader you will see the DSPMC file but don't try to run from it, use the default file or the file that you create for your machine.
If this is confusing you like it did me the first time I went through this. PM me and we can arrange a phone call.

Sorry for the delay in getting back to you but life got in the way again.

Mike
We never have the time or money to do it right the first time, but we somehow manage to do it twice and then spend the money to get it right.